net-im/skypeforlinux: Bump version to 8.33.0.41
authorJan Vesely <jano.vesely@gmail.com>
Thu, 25 Oct 2018 17:11:26 +0000 (13:11 -0400)
committerMichał Górny <mgorny@gentoo.org>
Fri, 26 Oct 2018 09:57:13 +0000 (11:57 +0200)
v2: Add elogind/systemd dependency
Signed-off-by: Jan Vesely <jano.vesely@gmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-im/skypeforlinux/Manifest
net-im/skypeforlinux/skypeforlinux-8.33.0.41.ebuild [new file with mode: 0644]

index 65bdba3823223a8b5b2a57a40aea067841b21dcd..993070f5ac0fde0f63c92eaa45571a28b17f39bf 100644 (file)
@@ -1 +1,2 @@
 DIST skypeforlinux_8.32.0.44-1.x86_64.rpm 96123759 BLAKE2B c362d1eaf2013514899225150cd47c1d0949d26dcefde58c6b2c14546aa8c56a1a4a5131996cb01115b77ae61afc3651ceabc58649c03ab058fdc208c3e51d3d SHA512 a51fdb7362f7b2e45a29869c18d3ae4475f9bfdc824e1b2862979e0c6a14378971c288bd48bcac09eeeaf532059975c615ed9504ee290ef1a1c32b431a75d6de
+DIST skypeforlinux_8.33.0.41-1.x86_64.rpm 96280740 BLAKE2B db751b800116587ae97600947372eaa655d438dfd6e70ad8e47d57bc4398ac47d4a01f49be7c9a0c1fb0606df8b0bad287577ada6da2999b384a01b3188e26f0 SHA512 f8c201f4da0f838982d64f51c9428d27bb4dd01f9eb753303600096406a1dc6d28af897985efb3f46bea9f0ef79708998e3e9308f92e2f0f4f42b1dca42b938b
diff --git a/net-im/skypeforlinux/skypeforlinux-8.33.0.41.ebuild b/net-im/skypeforlinux/skypeforlinux-8.33.0.41.ebuild
new file mode 100644 (file)
index 0000000..63b1b43
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop gnome2-utils pax-utils rpm multilib-build xdg-utils
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+       || (
+               sys-auth/elogind
+               sys-apps/systemd
+       )
+       dev-libs/atk[${MULTILIB_USEDEP}]
+       dev-libs/expat[${MULTILIB_USEDEP}]
+       dev-libs/glib:2[${MULTILIB_USEDEP}]
+       dev-libs/nspr[${MULTILIB_USEDEP}]
+       dev-libs/nss[${MULTILIB_USEDEP}]
+       gnome-base/gconf:2[${MULTILIB_USEDEP}]
+       media-libs/alsa-lib[${MULTILIB_USEDEP}]
+       media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+       media-libs/freetype:2[${MULTILIB_USEDEP}]
+       media-libs/libv4l[${MULTILIB_USEDEP}]
+       net-print/cups[${MULTILIB_USEDEP}]
+       sys-apps/dbus[${MULTILIB_USEDEP}]
+       sys-devel/gcc[cxx]
+       virtual/ttf-fonts
+       x11-libs/cairo[${MULTILIB_USEDEP}]
+       x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+       x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+       x11-libs/libX11[${MULTILIB_USEDEP}]
+       x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+       x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+       x11-libs/libXcursor[${MULTILIB_USEDEP}]
+       x11-libs/libXdamage[${MULTILIB_USEDEP}]
+       x11-libs/libXext[${MULTILIB_USEDEP}]
+       x11-libs/libXfixes[${MULTILIB_USEDEP}]
+       x11-libs/libXi[${MULTILIB_USEDEP}]
+       x11-libs/libXrandr[${MULTILIB_USEDEP}]
+       x11-libs/libXrender[${MULTILIB_USEDEP}]
+       x11-libs/libXtst[${MULTILIB_USEDEP}]
+       x11-libs/libxcb[${MULTILIB_USEDEP}]
+       x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+       x11-libs/pango[${MULTILIB_USEDEP}]"
+
+src_unpack() {
+       rpm_src_unpack ${A}
+}
+
+src_prepare() {
+       default
+       sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+               -i usr/bin/skypeforlinux || die
+       sed -e "s!^Exec=/usr/!Exec=${EPREFIX}/opt/!" \
+               -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+               -e "/^OnlyShowIn=/d" \
+               -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+       dodir /opt
+       cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+       into /opt
+       dobin usr/bin/skypeforlinux
+
+       dodoc usr/share/skypeforlinux/*.html
+       dodoc -r usr/share/doc/skypeforlinux/.
+       # symlink required for the "Help->3rd Party Notes" menu entry  (otherwise frozen skype -> xdg-open)
+       dosym ${P} usr/share/doc/skypeforlinux
+
+       doicon usr/share/pixmaps/skypeforlinux.png
+
+       # compat symlink for the autostart desktop file
+       dosym ../../opt/bin/skypeforlinux usr/bin/skypeforlinux
+
+       local res
+       for res in 16 32 256 512; do
+               newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+       done
+
+       domenu usr/share/applications/skypeforlinux.desktop
+
+       if use pax_kernel; then
+               pax-mark -m "${ED%/}"/opt/skypeforlinux/skypeforlinux
+               pax-mark -m "${ED%/}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+               ewarn "You have set USE=pax_kernel meaning that you intend to run"
+               ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+               ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
+               ewarn "you suspect that ${PN} is being broken by this modification,"
+               ewarn "please open a bug."
+       fi
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+       gnome2_icon_cache_update
+}