dev-python/pbr: Un-PYTHON_USEDEP dev-python/stestr
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 13:06:35 +0000 (14:06 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 13:33:54 +0000 (14:33 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pbr/pbr-4.2.0-r1.ebuild
dev-python/pbr/pbr-4.2.0-r2.ebuild
dev-python/pbr/pbr-5.1.1.ebuild

index a00a288a6d978db6b2e8ee73e37151e82cb19962..d63fe1d35c986a3f8bef9698f4c8842ef9cb9c32 100644 (file)
@@ -22,6 +22,7 @@ RESTRICT="!test? ( test )"
 
 # git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
 # docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
@@ -36,8 +37,8 @@ DEPEND="
                >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
                >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
                >=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
-               >=dev-python/stestr-2.1.0[$(python_gen_usedep python{2_7,3_5,3_6})]
                dev-python/wheel[${PYTHON_USEDEP}]
+               >=dev-python/stestr-2.1.0
                dev-vcs/git
        )"
 PDEPEND=""
index 8685cc63ab41cd3775ff698c23a901055ace982e..55e10b83667f867755f69d7728b371fa67e2a3fe 100644 (file)
@@ -22,6 +22,7 @@ RESTRICT="!test? ( test )"
 
 # git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
 # docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
@@ -36,9 +37,9 @@ DEPEND="
                >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
                >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
                >=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
-               >=dev-python/stestr-2.1.0[$(python_gen_usedep python{2_7,3_5,3_6})]
                dev-python/sphinx[${PYTHON_USEDEP}]
                dev-python/wheel[${PYTHON_USEDEP}]
+               >=dev-python/stestr-2.1.0
                dev-vcs/git
        )"
 PDEPEND=""
index 79cab5d13d398f842a82dea936d848bb2a038715..8b1069e5b667fe4078b0dd373617642a14b5a4b2 100644 (file)
@@ -22,6 +22,7 @@ RESTRICT="!test? ( test )"
 
 # git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
 # docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
@@ -37,13 +38,11 @@ DEPEND="
                >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
                >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
                >=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep '
-                       >=dev-python/stestr-2.1.0[${PYTHON_USEDEP}]
-               ' python{2_7,3_5,3_6,3_7})
                >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
                !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
                dev-python/sphinx[${PYTHON_USEDEP}]
                dev-python/wheel[${PYTHON_USEDEP}]
+               >=dev-python/stestr-2.1.0
                dev-vcs/git
        )"
 PDEPEND=""