net-analyzer/lft: EAPI=7, suppress some compiler warnings
authorJeroen Roovers <jer@gentoo.org>
Mon, 13 Apr 2020 09:16:46 +0000 (11:16 +0200)
committerJeroen Roovers <jer@gentoo.org>
Mon, 13 Apr 2020 09:16:56 +0000 (11:16 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/lft/lft-3.90.ebuild

index 03717b24b8ca035e3b4088db252b1da0a071531c..d874cf1a0c8c862a7bb9f8d3805a6359449ac13e 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 DESCRIPTION="Layer Four Traceroute (LFT) and WhoB"
 HOMEPAGE="http://pwhois.org/lft/"
@@ -22,6 +22,9 @@ S=${WORKDIR}/${P/0}
 DOCS=( CHANGELOG README TODO )
 
 src_prepare() {
+       sed -i -e 's:strip:true:g' Makefile.in || die
+       sed -i \
+               -e 's|_BSD_SOURCE|_DEFAULT_SOURCE|g' \
+               configure config/acconfig.h.in || die
        default
-       sed -i Makefile.in -e 's:strip:true:g' || die
 }