dev-python/pytest: Clean up old.
authorPatrice Clement <monsieurp@gentoo.org>
Sat, 19 Sep 2015 18:26:44 +0000 (18:26 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 19 Sep 2015 19:21:53 +0000 (19:21 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-python/pytest/Manifest
dev-python/pytest/pytest-2.7.1.ebuild [deleted file]

index dade778b9a4b0f741c2051fc6fc4c78cce632631..d9fee1586114ce9578dc23808918439f0141fb94 100644 (file)
@@ -1,3 +1,2 @@
-DIST pytest-2.7.1.tar.gz 531671 SHA256 530f23c79e1b13850e93f3a59720f1eca75bad01307dc4fd694a6a19619fb9cb SHA512 1bc23bf67a7400b48b718ef3a03591a3b2047d58b633c6eb16ca4732a9198b3fbbce5a2bfc93097322988b65498ee1a7278d7e035e10d91e6b58d1d3b2a61eba WHIRLPOOL d8eb985d967d8e4b48cab2df58b1e7415bb961087e9a53f4336dc830291b0aa5d4679a49429d6cd67510ec19470a397e07a7c505fd5555ee509c1ff508847b9c
 DIST pytest-2.7.2.tar.gz 532836 SHA256 b30457f735420d0000d10a44bbd478cf03f8bf20e25bd77248f9bab40f4fd6a4 SHA512 5474a4fe58437a4971fb21b1b37dad3c08e18e5d154931ff23e597f881100a3515bf0cf71d06b143465594ad2a91a96f84f4836d84c39691143c8d88ca7a4360 WHIRLPOOL 6ab7371f952109ac476774222883e1381fe5ee6a54d967f2d90765f6c59c90634a16c42e8e2e1661169db6a9cb1327242ff2281cf1caeabd86a4dacd24f4bb06
 DIST pytest-2.7.3.tar.gz 548235 SHA256 d5a9c3db3515ab95902ba08c09d1e941a21a440dc2d65f31bac02667508a9efc SHA512 ad9b57f202c60c247dd4753fb8391e3e88b390e34de678ea12384d81d76693dd37e04f11f6da19a6eda2c74a73db23789856ccaa325d32b4beb6bff86d9e4173 WHIRLPOOL 4aecd53142e503083abe2631bf403509c515d52176c430b7ab1e0becdf404e0fce4bad4343a4ab62525a6e008de0c35b4fac4a352d06938288dbf8deb8a4a250
diff --git a/dev-python/pytest/pytest-2.7.1.ebuild b/dev-python/pytest/pytest-2.7.1.ebuild
deleted file mode 100644 (file)
index 535b170..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ https://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.25"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-
-#pexpect dep based on https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       # Disable versioning of py.test script to avoid collision with
-       # versioning performed by the eclass.
-       sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
-       grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
-       # Prevent un-needed d'loading
-       sed -e "s/'sphinx.ext.intersphinx', //" -i doc/en/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               mkdir doc/en/.build || die
-               emake -C doc/en html
-       fi
-}
-
-python_test() {
-       # test_nose.py not written to suit py3.2 in pypy3
-       if [[ "${EPYTHON}" == pypy3 ]]; then
-               "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
-                       --ignore=testing/test_nose.py \
-                       || die "tests failed with ${EPYTHON}"
-       else
-               "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py \
-                       || die "tests failed with ${EPYTHON}"
-       fi
-}
-
-python_install_all() {
-       use doc && dohtml -r doc/en/_build/html/
-       distutils-r1_python_install_all
-}