dev-util/pkgcheck: Add missing any-of dep on snakeoil
authorMichał Górny <mgorny@gentoo.org>
Sat, 14 Dec 2019 17:35:10 +0000 (18:35 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 14 Dec 2019 17:49:06 +0000 (18:49 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/pkgcheck/pkgcheck-0.7.1.ebuild

index 8ab52c61b8ae17768ab8e6c96e5da46479e272f2..c4df9003bc227e98a3f1ea4d7e368361210241ac 100644 (file)
@@ -42,6 +42,7 @@ DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? ( $(python_gen_any_dep '
                dev-python/setuptools[${PYTHON_USEDEP}]
+               dev-python/snakeoil[${PYTHON_USEDEP}]
                dev-python/docutils[${PYTHON_USEDEP}]
                dev-python/sphinx[${PYTHON_USEDEP}]
        ') )
@@ -53,6 +54,7 @@ DEPEND="${RDEPEND}
 
 python_check_deps() {
        has_version "dev-python/setuptools[${PYTHON_USEDEP}]" || return 1
+       has_version "dev-python/snakeoil[${PYTHON_USEDEP}]" || return 1
        if use doc; then
                has_version "dev-python/docutils[${PYTHON_USEDEP}]" &&
                has_version "dev-python/sphinx[${PYTHON_USEDEP}]"