dev-python/setuptools_scm_git_archive: Add package needed by pyclipper
authorPacho Ramos <pacho@gentoo.org>
Mon, 15 Oct 2018 21:26:05 +0000 (23:26 +0200)
committerPacho Ramos <pacho@gentoo.org>
Mon, 15 Oct 2018 21:27:06 +0000 (23:27 +0200)
Bug: https://bugs.gentoo.org/668726
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/setuptools_scm_git_archive/Manifest [new file with mode: 0644]
dev-python/setuptools_scm_git_archive/metadata.xml [new file with mode: 0644]
dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/setuptools_scm_git_archive/Manifest b/dev-python/setuptools_scm_git_archive/Manifest
new file mode 100644 (file)
index 0000000..142571b
--- /dev/null
@@ -0,0 +1 @@
+DIST setuptools_scm_git_archive-1.0.tar.gz 2553 BLAKE2B a5ed592384800585b3f58b40571edc929872908bcb5e2d012cefe34e6cd84ee420a3bbbb9e856ef0fbbb972931abb4913d245b98d54b82aaf659247b92a1303e SHA512 fd1a06c86d1a8394e37b91d374b93dd5902906795360688b49077a4530240fd6be575ee66d51c3f61931bc837711bc3c59491d7c9cd165c34e2ec1f314b4cfbc
diff --git a/dev-python/setuptools_scm_git_archive/metadata.xml b/dev-python/setuptools_scm_git_archive/metadata.xml
new file mode 100644 (file)
index 0000000..3da97a9
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>pacho@gentoo.org</email>
+               <name>Pacho Ramos</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.0.ebuild b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.0.ebuild
new file mode 100644 (file)
index 0000000..350a0c1
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A setuptools_scm plugin for git archives"
+HOMEPAGE="https://github.com/Changaco/setuptools_scm_git_archive"
+SRC_URI="https://github.com/Changaco/setuptools_scm_git_archive/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       esetup.py test
+}