dev-python/python-discid: add 1.1.1
authorDavid Hicks <david@hicks.id.au>
Mon, 13 Mar 2017 11:56:22 +0000 (22:56 +1100)
committerDavid Seifert <soap@gentoo.org>
Thu, 16 Mar 2017 19:11:17 +0000 (20:11 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Closes: https://github.com/gentoo/gentoo/pull/4197

dev-python/python-discid/Manifest
dev-python/python-discid/python-discid-1.1.1.ebuild [new file with mode: 0644]

index 1154ea7eafb6741a1948cbab97a8dd596a8bbf35..abeca968876271745ac52311eda99ef1ed4e7cac 100644 (file)
@@ -1 +1,2 @@
 DIST python-discid-1.1.0.tar.gz 30656 SHA256 823fbf06f1f08f4e3738c5a68349075a8a3b219c6009fe2af55a0277b9122031 SHA512 dd4a0a406d3f1b1d635bfb12c52689b72296f6965dd5d23c540d137ac60841bc39722e710db459281511df992e4db6614472cc741084bebe2ecf6b0b4dc5ab36 WHIRLPOOL 6c0ef1cdd3c4747defc6e717a09dffe79f231fb8b5fff40b1a5b2e4bcf53532e551bc07eaec96f2b075162a6f6c449a55e3efa9875b9e403937e0033d6da0349
+DIST python-discid-1.1.1.tar.gz 30454 SHA256 5ed31ea16d752c0188f2d090cc60c38d8ca2a8b6e6dfb71a22499ca403aca19a SHA512 b040137162a2588c653f390a4d0b549b322bb4e2745a3738c1ba72a1984722358fc85a306f4cd5d41c1e599e40d01c6e2b08d67951a820c2d1116d96eb618c8e WHIRLPOOL 1a823b77db78e8706fec233b8b13a30b2fbb66fe146df7586114d9ca3ee539927048429c0c0b078fdd44118b8cbc00305d9c7f2494ff6870b4742b9da6b80810
diff --git a/dev-python/python-discid/python-discid-1.1.1.ebuild b/dev-python/python-discid/python-discid-1.1.1.ebuild
new file mode 100644 (file)
index 0000000..3162cd2
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libdiscid"
+HOMEPAGE="https://github.com/JonnyJD/python-discid"
+SRC_URI="https://github.com/JonnyJD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=media-libs/libdiscid-0.2.2"
+DEPEND="
+       ${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+       if use doc; then
+               cd doc || die
+               sphinx-build . _build/html || die
+               HTML_DOCS=( doc/_build/html/. )
+       fi
+}
+
+python_test() {
+       esetup.py test
+}