dev-python/future: Add python-3.6, fix tests
authorBrian Dolbec <dolsen@gentoo.org>
Tue, 4 Apr 2017 19:37:01 +0000 (12:37 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Tue, 4 Apr 2017 23:04:13 +0000 (16:04 -0700)
Change the tests to use py.test. esetup.py test had some strange
cross python interactions causing test failures.
Determined by: Manuel Rueg <mrueg>

Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30

dev-python/future/future-0.16.0.ebuild

index db3e9a25611317143fdfaa3cbf4cca059b7f9853..2e0860cc850af6dba86853b5123785b793f57ba3 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
 
 inherit distutils-r1
 
@@ -14,8 +14,14 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~x86"
-IUSE=""
+IUSE="test"
+
+DEPEND="
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )
+"
 
 python_test() {
-       esetup.py test || die
+       py.test -v || die "Tests failed under ${EPYTHON}"
 }