games-mud/lyntin: remove deprecated games eclass
authorAustin English <wizardedit@gentoo.org>
Fri, 5 Aug 2016 19:05:34 +0000 (14:05 -0500)
committerAustin English <wizardedit@gentoo.org>
Fri, 5 Aug 2016 19:43:17 +0000 (14:43 -0500)
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0

games-mud/lyntin/lyntin-4.2-r2.ebuild [new file with mode: 0644]

diff --git a/games-mud/lyntin/lyntin-4.2-r2.ebuild b/games-mud/lyntin/lyntin-4.2-r2.ebuild
new file mode 100644 (file)
index 0000000..481a4be
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk?"
+
+inherit distutils-r1
+
+DESCRIPTION="tintin mud client clone implemented in Python"
+HOMEPAGE="http://lyntin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lyntin/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="tk"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS=( COMMANDS PKG-INFO HACKING README )
+
+python_install() {
+       distutils-r1_python_install --install-scripts=/usr/bin
+}
+
+src_prepare() {
+       distutils-r1_src_prepare
+}
+
+src_compile() {
+       distutils-r1_src_compile
+}
+
+src_install() {
+       distutils-r1_src_install
+}
+
+pkg_postinst() {
+       if use tk ; then
+               elog "To start lyntin in GUI mode, create a config file"
+               elog "with this in it:"
+               elog
+               elog "[Lyntin]"
+               elog "ui:    tk"
+               elog
+               elog "Then start lyntin like this:"
+               elog
+               elog "runlyntin -c /path/to/config_file\n"
+       fi
+}