dev-python/python-recaptcha: Initial commit.
authorHanno <hanno@gentoo.org>
Wed, 21 Mar 2018 14:05:59 +0000 (15:05 +0100)
committerHanno <hanno@gentoo.org>
Wed, 21 Mar 2018 14:05:59 +0000 (15:05 +0100)
Fork of dev-python/recaptcha-client supporting recaptcha v2.

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-python/python-recaptcha/Manifest [new file with mode: 0644]
dev-python/python-recaptcha/metadata.xml [new file with mode: 0644]
dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-recaptcha/Manifest b/dev-python/python-recaptcha/Manifest
new file mode 100644 (file)
index 0000000..97c36af
--- /dev/null
@@ -0,0 +1 @@
+DIST python-recaptcha-2.0.0.tar.gz 5556 BLAKE2B b752915eb95343d7cbce483f49ce9d93ecf837c85a1615e414e14226c54dc60ede3187bd127e09769106a7eb06156ab2b73b0a3839743c29b6aba6e6c4d96951 SHA512 3a60062f36833888a110d5979ca7a7f46cef927bfcf427aba72d2f6a99a9c401b20bea997ff8fb2b8435876bed3880371a84568b95da1341940d275cba8ff178
diff --git a/dev-python/python-recaptcha/metadata.xml b/dev-python/python-recaptcha/metadata.xml
new file mode 100644 (file)
index 0000000..97e2d6e
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>hanno@gentoo.org</email>
+  </maintainer>
+  <maintainer type="project">
+    <email>python@gentoo.org</email>
+    <name>Python</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="github">redhat-infosec/python-recaptcha</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild b/dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..e77a895
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for reCAPTCHA and reCAPTCHA Mailhide"
+HOMEPAGE="https://github.com/redhat-infosec/python-recaptcha"
+SRC_URI="https://github.com/redhat-infosec/python-recaptcha/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+       dev-python/simplejson[${PYTHON_USEDEP}]
+       !dev-python/recaptcha-client"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+       distutils-r1_python_install
+       # otherwise we have an empty recaptcha dir/namespace
+       touch "${D}$(python_get_sitedir)"/recaptcha/__init__.py
+}