media-libs/theoraplay: New package
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 8 Jun 2019 21:44:38 +0000 (22:44 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 8 Jun 2019 21:44:38 +0000 (22:44 +0100)
Library by icculus needed for some games. It is not versioned as it is
normally built as part of the games but when used with the FNA game
engine, a shared library is needed. The ABI doesn't appear to have
changed since it was open sourced.

Package-Manager: Portage-2.3.67, Repoman-2.3.13
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
media-libs/theoraplay/Manifest [new file with mode: 0644]
media-libs/theoraplay/metadata.xml [new file with mode: 0644]
media-libs/theoraplay/theoraplay-0_pre20180524.ebuild [new file with mode: 0644]

diff --git a/media-libs/theoraplay/Manifest b/media-libs/theoraplay/Manifest
new file mode 100644 (file)
index 0000000..68b50ab
--- /dev/null
@@ -0,0 +1 @@
+DIST theoraplay-0_pre20180524.tar.bz2 14504 BLAKE2B 99580d65574887c283c8d7d1a588783bdb91ea5570adb4e194919ed930be558d62ddbd10e451746aa47bd6996cc3102f0b1eee50308cc278c2c6368a2a76d244 SHA512 509815535f73efe3b1c602b425d4a0aa78ce744809e8242fdfdecbb74a3a765d80b8e565dbdd00cd2daaf122365ba5a8651d302c907c714eae97f64607b7d0b8
diff --git a/media-libs/theoraplay/metadata.xml b/media-libs/theoraplay/metadata.xml
new file mode 100644 (file)
index 0000000..26079e6
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>games@gentoo.org</email>
+               <name>Gentoo Games Project</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild b/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild
new file mode 100644 (file)
index 0000000..487a8f8
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib multilib-minimal toolchain-funcs
+
+COMMIT="7d8701876294"
+DESCRIPTION="Simple library to make decoding of Ogg Theora videos easier"
+HOMEPAGE="https://icculus.org/projects/theoraplay/"
+SRC_URI="https://hg.icculus.org/icculus/${PN}/archive/${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       media-libs/libogg
+       media-libs/libtheora
+       media-libs/libvorbis
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+multilib_src_compile() {
+       libtool --tag=CC --mode=compile $(tc-getCC) -shared ${CFLAGS} -pthread -c "${S}"/${PN}.c || die
+       libtool --tag=CC --mode=link $(tc-getCC) -shared ${LDFLAGS} -pthread -Wl,-z,defs ${PN}.lo \
+                       -logg -ltheoradec -lvorbis -o lib${PN}.la -rpath "${EPREFIX}/usr/$(get_libdir)" || die
+}
+
+multilib_src_install() {
+       dolib.so .libs/lib${PN}$(get_libname)*
+}
+
+multilib_src_install_all() {
+       doheader ${PN}.h
+}