dev-python/requests-mock: bump to 1.7.0, add Py3.8, improve ebuild
authorLouis Sautier <sbraz@gentoo.org>
Sat, 29 Feb 2020 00:39:46 +0000 (01:39 +0100)
committerLouis Sautier <sbraz@gentoo.org>
Sat, 29 Feb 2020 00:46:34 +0000 (01:46 +0100)
* Rely on distutils_enable_* functions.
* Run tests the standard way, get rid of unneeded test dependencies.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/requests-mock/Manifest
dev-python/requests-mock/requests-mock-1.7.0.ebuild [new file with mode: 0644]

index 8822b19bf452aac7516dec3f9a78e89fecf2e1d5..335707e7e342be88a1020fb08ad6232ad5425318 100644 (file)
@@ -1,3 +1,4 @@
 DIST requests-mock-1.2.0.tar.gz 40219 BLAKE2B b5ded6c97d920bab0c610c1be1c80f299e56cccd393c824b5c9ab3e0c298491b8be0b285c440bc8ba32eb1eec2eca14ec363d0f188c5b095192a56d01383c322 SHA512 ed24d1809aef597219ae2b0b376156a0760040795ccd660ee38f84cd1ceed58cbc5009764d7a365d31f941ee16e2b537b92ddcff92bcd8d47b7e95c67dc8d82c
 DIST requests-mock-1.5.0.tar.gz 47824 BLAKE2B 90d540e2372430c70b0ada0bc48a3a8085452e062e9ab57a232d080df8312c2a722c01d61fb399fe2a6bc31a2d6d61914d8d0e2c912a2e439062b27bb31914cf SHA512 21838017ac4d3066e2240b40b27bbe16f3bd989f37eba90f0a0d0cdb997e7e65c6d9dc63b31f64daaa6146cc3c6bccbba86382eda3f2ca72eb7cc8381969af36
 DIST requests-mock-1.5.2.tar.gz 47581 BLAKE2B 46beefc45e01355939a76b85e43a5b57cb1a870666eab7f610cad3e8a04a17da6a0864f9776a0f09028c847e8a4f7d0d2389a36f9a0431ed733a364d0f712c0b SHA512 206c91e892df84e38dcdf1264559128cfece76be2ce43b9c98238dfd438795d8c4ce3fcd43feb30246fbfca2d78832a23430ce1c9d3a7dc6e4417df5d65a8d3c
+DIST requests-mock-1.7.0.tar.gz 51705 BLAKE2B 1104422ab28678ee9e964fd853e7d61c23bc2f0dfb3861c2829578d1f91d533d195ce687fbc8596aba32da4b369050398d891125dc894e55fcb73ca81268b30c SHA512 6ad71fb87519f93812e8ae0d058a4b65a4492e86f05cacc37f95be1a6f0239a2c3f3d20a7e6f44bcc21f009574e4e78c2149394c2570d305efbdd68ec07b24a2
diff --git a/dev-python/requests-mock/requests-mock-1.7.0.ebuild b/dev-python/requests-mock/requests-mock-1.7.0.ebuild
new file mode 100644 (file)
index 0000000..7c051fe
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+       >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+       test? (
+               dev-python/fixtures[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/testtools[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests unittest
+
+python_prepare_all() {
+       # Disable reno which only works inside a git repository
+       sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
+       # Remove the release notes section which requires reno
+       rm doc/source/release-notes.rst || die
+       sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
+       # Disable a test which requires purl (not in the tree)
+       sed -i -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
+               tests/test_adapter.py || die
+       distutils-r1_python_prepare_all
+}