dev-util/bdelta: bump up to EAPI=7
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 9 Nov 2019 16:29:31 +0000 (16:29 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 9 Nov 2019 16:29:38 +0000 (16:29 +0000)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-util/bdelta/bdelta-0.3.1-r1.ebuild

index 9bbc378a96af254505ff8b4e987733f3aca6118a..bf1c9ae4ddbf3a812e8d3391ac9be57f02018538 100644 (file)
@@ -1,21 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-if [[ ${PV} = *9999* ]]; then
-       EGIT_REPO_URI="https://github.com/jjwhitney/BDelta.git"
-       UNPACKER_ECLASS="git-2"
-       LIVE_EBUILD=yes
-else
-       UNPACKER_ECLASS="vcs-snapshot"
-fi
-
-inherit toolchain-funcs ${UNPACKER_ECLASS}
+inherit toolchain-funcs vcs-snapshot
 
 if [[ -z ${LIVE_EBUILD} ]]; then
        KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux"
-       SRC_URI="https://github.com/jjwhitney/BDelta/tarball/v${PV} -> ${P}.tar.gz"
+       SRC_URI="https://github.com/jjwhitney/BDelta/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 fi
 
 DESCRIPTION="Binary Delta - Efficient difference algorithm and format"