dev-java/jnr-unixsocket: Bump Java version to 7 as jnr-enxio also has
authorJames Le Cuirot <chewi@gentoo.org>
Thu, 24 Sep 2015 15:18:03 +0000 (16:18 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Thu, 24 Sep 2015 15:18:45 +0000 (16:18 +0100)
This relates to bug #561352. jnr-unixsocket builds with Java 6 but it
should have a Java version at least as high as its dependencies.

I have also changed the jnr-ffi SLOT to match the one used by
jnr-enxio, otherwise you end up with two conflicting versions on the
classpath. jruby (a revdep) also uses the older version but it is
masked and totally broken anyway.

This demands a revbump but should still be safe enough to commit
straight to stable.

Package-Manager: portage-2.2.20.1

dev-java/jnr-unixsocket/jnr-unixsocket-0.6-r1.ebuild [moved from dev-java/jnr-unixsocket/jnr-unixsocket-0.6.ebuild with 86% similarity]

similarity index 86%
rename from dev-java/jnr-unixsocket/jnr-unixsocket-0.6.ebuild
rename to dev-java/jnr-unixsocket/jnr-unixsocket-0.6-r1.ebuild
index e1a54ccc7f336f92ba105e0c0ba165829bcc0089..f5936f9bbe6fd60e54827de9a9534da4f222c821 100644 (file)
@@ -19,20 +19,20 @@ LICENSE="Apache-2.0"
 CDEPEND="dev-java/jnr-constants:0
        dev-java/jnr-enxio:0
        dev-java/jnr-posix:3.0
-       dev-java/jnr-ffi:0.7"
+       dev-java/jnr-ffi:2"
 
 DEPEND="${CDEPEND}
-       >=virtual/jdk-1.6"
+       >=virtual/jdk-1.7"
 
 RDEPEND="${CDEPEND}
-       >=virtual/jre-1.6"
+       >=virtual/jre-1.7"
 
 java_prepare() {
        cp "${FILESDIR}"/${P}-build.xml build.xml || die
 }
 
 JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="jnr-constants,jnr-enxio,jnr-ffi-0.7,jnr-posix-3.0"
+EANT_GENTOO_CLASSPATH="jnr-constants,jnr-enxio,jnr-ffi-2,jnr-posix-3.0"
 
 src_install() {
        java-pkg_newjar target/${P}.jar ${PN}.jar