net-libs/libhubbub: bump to 0.3.6 and fix for json-c issue.
authorJaco Kroon <jaco@uls.co.za>
Wed, 6 Nov 2019 11:27:23 +0000 (13:27 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 12 Nov 2019 14:45:29 +0000 (16:45 +0200)
Also add myself as proxy maintainer.  Others are welcome to contribute,
my only interest here is in libwebsockets.

Closes: https://bugs.gentoo.org/694042
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Jaco Kroon <jaco@uls.co.za>
Closes: https://github.com/gentoo/gentoo/pull/13566
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-libs/libhubbub/Manifest
net-libs/libhubbub/files/libhubbub-0.3.6-json-c.patch [new file with mode: 0644]
net-libs/libhubbub/libhubbub-0.3.6.ebuild [new file with mode: 0644]
net-libs/libhubbub/metadata.xml

index 737a61e65416ecb25a86141e8ff0775bc1ca6ba3..199df49861d2666085f1ad838f0767404a6a191b 100644 (file)
@@ -1,3 +1,4 @@
 DIST libhubbub-0.3.3-src.tar.gz 783945 BLAKE2B 826b089708dea8a88a522f9889f81e420feb6c616ef7ad826303eca3ab39d4940cbc8bcbfcf61c979dc488d77b4d32fb24c0602b73ed28ea4e8076f369c93388 SHA512 28a5668257eda8cf1ca0395505522eb0f847a4cceee46de067fcfb171baa114876156a7e2671fff93602b2de63c640095e1a940e4725afb24bd14b4fd5f64526
 DIST libhubbub-0.3.5-src.tar.gz 784526 BLAKE2B a7ba1be85ab01761894a1f2904fbcfbada0280c06ad0834288366f9ce42407a61978bbd775367cc064e367ad78bc792db66ad0e034ae6903c8ad5b44a1fc4d08 SHA512 57feb6ae74381e6b2c5c8a82aef7bcc5faf4a8303e41e39f4ba081a198c6f1225ec9952734ec97f20ba1b4fa3830543e43f4c2d2715b7a8467c19224a968073b
+DIST libhubbub-0.3.6-src.tar.gz 784692 BLAKE2B a24b2c7b33849d6f4b25867f8b801d157f19257a055dd9a5a6c49de6c2fbd3f234f648d542b7938fab249e14bb6839997530c47b931379a94ab85ccd750b71e0 SHA512 6ccf9d9bbe8fc8de21570994c4a2f6f6c6943d2b00b8939d0ec9ec72cb3d653c40b58f509a1a81a5500fc8d3b4c49595aec509129bc993208b51b29486d0c14f
 DIST netsurf-buildsystem-1.5.tar.gz 38196 BLAKE2B 298ef39d45b98ae5ef57a22aed9f22bf96dfd6ad5475964c04451eaf28aca7f451b4906002c3e110ffcc951015169f02ffcd85f24e54b46c47b25e048115db1c SHA512 02d85e8f1d2101194a678f7ccf84051390953285a46951d7b327556f8df1a0c416620bd4c7a615e25de438d5d27cfffb69ec5d94eb8379a295dab4c85a96cae4
diff --git a/net-libs/libhubbub/files/libhubbub-0.3.6-json-c.patch b/net-libs/libhubbub/files/libhubbub-0.3.6-json-c.patch
new file mode 100644 (file)
index 0000000..763693e
--- /dev/null
@@ -0,0 +1,24 @@
+diff -u -rb libhubbub-0.3.6/test.o/tokeniser2.c libhubbub-0.3.6/test/tokeniser2.c
+--- libhubbub-0.3.6/test.o/tokeniser2.c        2019-06-26 22:39:57.000000000 +0200
++++ libhubbub-0.3.6/test/tokeniser2.c  2019-11-06 13:09:02.321068038 +0200
+@@ -48,7 +48,7 @@
+       }
+       json = json_object_from_file(argv[1]);
+-      assert(!is_error(json));
++      assert(json);
+       assert(strcmp((char *) ((json_object_get_object(json)->head)->k),
+                       "tests") == 0);
+diff -u -rb libhubbub-0.3.6/test.o/tokeniser3.c libhubbub-0.3.6/test/tokeniser3.c
+--- libhubbub-0.3.6/test.o/tokeniser3.c        2019-06-26 22:39:57.000000000 +0200
++++ libhubbub-0.3.6/test/tokeniser3.c  2019-11-06 13:13:03.162538564 +0200
+@@ -46,7 +46,7 @@
+       }
+       json = json_object_from_file(argv[1]);
+-      assert(!is_error(json));
++      assert(json);
+       assert(strcmp((char *) ((json_object_get_object(json)->head)->k),
+                       "tests") == 0);
diff --git a/net-libs/libhubbub/libhubbub-0.3.6.ebuild b/net-libs/libhubbub/libhubbub-0.3.6.ebuild
new file mode 100644 (file)
index 0000000..7a2bdd8
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="HTML5 compliant parsing library, written in C"
+HOMEPAGE="https://www.netsurf-browser.org/projects/hubbub/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~m68k-mint"
+IUSE="doc test"
+
+BDEPEND="
+       dev-util/netsurf-buildsystem
+       virtual/pkgconfig
+
+       test? ( dev-lang/perl )
+"
+RDEPEND="dev-libs/libparserutils:="
+DEPEND="${RDEPEND}
+       test? ( dev-libs/json-c )"
+RESTRICT="!test? ( test )"
+
+DOCS=( README docs/{Architecture,Macros,Todo,Treebuilder,Updated} )
+PATCHES=( "${FILESDIR}/libhubbub-0.3.6-json-c.patch" )
+
+src_prepare() {
+       default
+       sed -e '1i#pragma GCC diagnostic ignored "-Wimplicit-fallthrough"' \
+               -i test/tree2.c || die
+}
+
+_emake() {
+       source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
+       netsurf_define_makeconf
+       append-cflags -Wno-error
+       emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+}
+
+src_compile() {
+       _emake
+}
+
+src_test() {
+       _emake test
+}
+
+src_install() {
+       _emake DESTDIR="${ED}" install
+}
index 7a38bb9009641b7a25f4778d890670fd5ab0e8e1..64b17e08bff5025ab4eb82fa4475e4aef1830b83 100644 (file)
@@ -1,5 +1,12 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>jaco@uls.co.za</email>
+               <name>Jaco Kroon</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
 </pkgmetadata>