dev-util/clion: remove old versions
authorChristian Strahl <c.a.strahl@gmail.com>
Mon, 9 Sep 2019 12:16:01 +0000 (14:16 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 15 Sep 2019 16:48:43 +0000 (19:48 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Christian Strahl <c.a.strahl@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12890
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-util/clion/Manifest
dev-util/clion/clion-2019.2.ebuild [deleted file]

index 02134953746d90a6756510b56938ef8d64323eaf..45b11b461f5985391f94e7190a5e06f13da9bbc7 100644 (file)
@@ -1,2 +1 @@
 DIST clion-2019.2.1.tar.gz 493159056 BLAKE2B 8264befab42af1a73f9332a9a1bbfc91e9bf09108b0a544d18296feafd200f6c0013be768a5f7dfba29da689903945d81e54b95291d0952c2336be98b0f6357f SHA512 ed96df5872f0c3d911df15b3d00e045df5726d0d4d70225ace2b41b2e8e7ab3c04f22a8f00e9232472853a5ff5baa62b8b2363fbb6d68ba785a74e34c05d4abc
-DIST clion-2019.2.tar.gz 485913295 BLAKE2B db723c1785cdf09f35299f89bb89f21c4f4ea96cc89de73484e31d042088cf613f634fc16e4c9d927f6903be3c401002836c0628cb80be7b029c4b28a67515ee SHA512 eb0a1acb9f267fa36f3cb2924cd9caa2f84367401c271d99458fc90b40cd62f97f566270ef1cd03bd0ce4160ab4bc92182fd468b860c67f2358e3c6adb021ddb
diff --git a/dev-util/clion/clion-2019.2.ebuild b/dev-util/clion/clion-2019.2.ebuild
deleted file mode 100644 (file)
index b336045..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop eutils
-
-DESCRIPTION="A complete toolset for C and C++ development"
-HOMEPAGE="https://www.jetbrains.com/clion"
-SRC_URI="https://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="IDEA
-       || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror splitdebug"
-IUSE="custom-jdk"
-
-# RDEPENDS may cause false positives in repoman.
-# clion requires cmake and gdb at runtime to build and debug C/C++ projects
-RDEPEND="
-       dev-util/cmake
-       sys-devel/gdb
-       !custom-jdk? ( virtual/jdk )"
-
-QA_PREBUILT="opt/${P}/*"
-
-src_prepare() {
-       default
-
-       local remove_me=(
-               bin/gdb/linux
-               bin/lldb/linux
-               bin/cmake
-               license/CMake*
-               lib/pty4j-native/linux/ppc64le
-       )
-
-       use amd64 || remove_me+=( bin/fsnotifier64 lib/pty4j-native/linux/x86_64)
-       use arm || remove_me+=( bin/fsnotifier-arm )
-       use x86 || remove_me+=( bin/fsnotifier lib/pty4j-native/linux/x86)
-
-       use custom-jdk || remove_me+=( jbr )
-
-       rm -rv "${remove_me[@]}" || die
-}
-
-src_install() {
-       local dir="/opt/${P}"
-
-       insinto "${dir}"
-       doins -r *
-       fperms 755 "${dir}"/bin/{clion.sh,clang/linux/clang{d,-tidy}}
-
-       if use amd64; then
-               fperms 755 "${dir}"/bin/fsnotifier64
-       fi
-       if use arm; then
-               fperms 755 "${dir}"/bin/fsnotifier-arm
-       fi
-       if use x86; then
-               fperms 755 "${dir}"/bin/fsnotifier
-       fi
-
-       if use custom-jdk; then
-               if [[ -d jbr ]]; then
-               fperms 755 "${dir}"/jbr/bin/{jaotc,java,javac,jdb,jjs,jrunscript,keytool,pack200,rmid,rmiregistry,serialver,unpack200}
-               fi
-       fi
-
-       make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
-       newicon "bin/${PN}.svg" "${PN}.svg"
-       make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
-
-       # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
-       dodir /usr/lib/sysctl.d/
-       echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
-}