media-gfx/openscad: fix compilation with boost-1.72
authorChristophe Lermytte <gentoo@lermytte.be>
Tue, 17 Dec 2019 17:39:22 +0000 (18:39 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 20 Dec 2019 05:34:12 +0000 (07:34 +0200)
Patch originates from upstream commit which is staged for release
https://github.com/openscad/openscad/pull/3105

Closes: https://bugs.gentoo.org/703022
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Christophe Lermytte <gentoo@lermytte.be>
Closes: https://github.com/gentoo/gentoo/pull/14028
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-gfx/openscad/files/openscad-2019.05_fix-boost-1.72.0-build.patch [new file with mode: 0644]
media-gfx/openscad/openscad-2019.05-r1.ebuild

diff --git a/media-gfx/openscad/files/openscad-2019.05_fix-boost-1.72.0-build.patch b/media-gfx/openscad/files/openscad-2019.05_fix-boost-1.72.0-build.patch
new file mode 100644 (file)
index 0000000..28d3285
--- /dev/null
@@ -0,0 +1,27 @@
+From b6c170cc5dd1bc677176ee732cdb0ddae57e5cf0 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Fri, 25 Oct 2019 15:10:26 +0000
+Subject: [PATCH] Add missing header bootlegged by Boost < 1.72
+
+src/parser.y:76:6: error: no template named 'stack' in namespace 'std'
+std::stack<LocalScope *> scope_stack;
+~~~~~^
+---
+ src/parser.y | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/parser.y b/src/parser.y
+index 7f4fd56c..4c77c989 100644
+--- a/src/parser.y
++++ b/src/parser.y
+@@ -46,6 +46,7 @@
+ #include "printutils.h"
+ #include "memory.h"
+ #include <sstream>
++#include <stack>
+ #include <boost/filesystem.hpp>
+ #include "boost-utils.h"
+ #include "feature.h"
+-- 
+2.24.1
+
index 8991b255f4ca3ab98bb40996fe118f0cc192875a..11211477d2d1a5471a85153a0772289c2a9ac35b 100644 (file)
@@ -16,6 +16,10 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="emacs"
 
+PATCHES=(
+       "${FILESDIR}/${PN}-2019.05_fix-boost-1.72.0-build.patch"
+)
+
 # FIXME: add optional lib3mf
 RDEPEND="
        dev-cpp/eigen:3