dev-libs/libressl: version bump to 2.7.2
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 1 Apr 2018 22:31:47 +0000 (18:31 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 1 Apr 2018 22:42:42 +0000 (18:42 -0400)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-libs/libressl/Manifest
dev-libs/libressl/libressl-2.7.2.ebuild [new file with mode: 0644]

index f4af8fb22f6e3694c88c53b4366c27c95b78b79c..16d2adf85a84101f83aaabf1428c1e9a6651a3bf 100644 (file)
@@ -10,3 +10,4 @@ DIST libressl-2.6.3.tar.gz 3228661 BLAKE2B 01d1e09a5c4541e1d6b35d0a1cd9246671a7c
 DIST libressl-2.6.4.tar.gz 3227935 BLAKE2B 48e865448a9e5b0b604b06060091073276aebd376506de73773a5eb9cb0bb4c5b93aa16353b4892abaee97ec933ad77e89775c3f52263d77bb17c68e481b4f70 SHA512 181761da573ff392aaee17dd3dde416d7cbb299ab3e07b49c97e279ceb3f619e78d1dc9ec4c59b0af024f0a8270ff31fe37f8282d0392be34c3143c9647cd246
 DIST libressl-2.7.0.tar.gz 3286436 BLAKE2B 883f24f70dc39c0547d63b852274ce12e03910d5b8eced70dbcffb062d236ad03b3e7dc0c265277f33666616f682b454130be18fb2f8112d42aabcaab8882a69 SHA512 d0e51fa7143f71266e9193fbda151c6e65ba403fa93b4030edcfd4909f5905b03586cc5605e58a62a190d46e9caf7191b6572106b8e92bc5400b2e1b6b7e025e
 DIST libressl-2.7.1.tar.gz 3362461 BLAKE2B 48b62160298ea7628c6671271b7ae9249cc3355cf6e504b504f7fef4ce62337f07e0a8117eef88fee7ae2a0517859f83e8540003dfd2c577f10841088d9eb180 SHA512 b7adc4250ba3fa5a3db20890aacb6b40dc9fbc29cc470c55dc9742430b9ba10ec122e6edf6f1671d77dea6347be1a23dc3d81b3b70f9b6e722212f356c36dfbc
+DIST libressl-2.7.2.tar.gz 3364227 BLAKE2B 49da6903a63425ac246c574b4c842706eaff184ba4a1768f61b2007296cb915f944f80f79edbad12b1a28a5552282522aa2b037195e2f917c06cf6917f1642e6 SHA512 12d00d057d449eb4119fc2f07034ebc0f1bbcb1602c0e07ef03b50440045eafd70594ddee352946cd9409aed8aceeb6988ba1643f582566fe3498499d94ece49
diff --git a/dev-libs/libressl/libressl-2.7.2.ebuild b/dev-libs/libressl/libressl-2.7.2.ebuild
new file mode 100644 (file)
index 0000000..af207c4
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so.  Since these can differ,
+# we'll try to use the max of either.  However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/45"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS=""
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+       touch crypto/Makefile.in
+
+       sed -i \
+               -e '/^[ \t]*CFLAGS=/s#-g ##' \
+               -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+               -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+               -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+               -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+               -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+               configure || die "fixing CFLAGS failed"
+
+       eapply_user
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable asm) \
+               $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+       emake check
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       prune_libtool_files
+}