sys-devel/binutils-apple: force gcc-apple usage if necessary
authorFabian Groffen <grobian@gentoo.org>
Thu, 13 Dec 2018 08:34:24 +0000 (09:34 +0100)
committerFabian Groffen <grobian@gentoo.org>
Thu, 13 Dec 2018 08:34:59 +0000 (09:34 +0100)
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

sys-devel/binutils-apple/binutils-apple-3.2.ebuild

index 9469e8bf164b61ae82cc573098204b6a61d5b4e7..55a843d9c6c7c023ad4470f81e37742eebc8150c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -121,6 +121,12 @@ src_configure() {
        else
                BINPATH=/usr/${CTARGET}/binutils-bin/${PV}
        fi
+
+       if tc-is-gcc && [[ $(gcc-fullversion) != 4.2.1 ]] ; then
+               # force gcc-apple
+               CC=${CTARGET}-gcc-4.2.1
+               CXX=${CTARGET}-g++-4.2.1
+       fi
 }
 
 compile_ld64() {