sci-libs/cxsparse: Add 32bit support
authorJustin Lecher <jlec@gentoo.org>
Sun, 22 Jan 2017 10:13:51 +0000 (10:13 +0000)
committerJustin Lecher <jlec@gentoo.org>
Sun, 22 Jan 2017 10:21:13 +0000 (10:21 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-libs/cxsparse/cxsparse-3.1.2.ebuild
sci-libs/cxsparse/metadata.xml

index 866f663331088ca78ea3d94a232bbaba74133765..f3e828931624688848ae044529ca68fa3c64f918 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
-inherit autotools-utils
+inherit multilib-minimal
 
 DESCRIPTION="Extended sparse matrix package"
 HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CXSparse/"
@@ -15,6 +15,18 @@ SLOT="0"
 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
 IUSE="static-libs"
 
-RDEPEND="sci-libs/suitesparseconfig"
+RDEPEND="sci-libs/suitesparseconfig[${MULTILIB_USEDEP}]"
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" \
+               econf \
+               $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+       if ! use static-libs; then
+               find "${ED}" -name "*.la" -delete || die
+       fi
+}
index d0d5fedd4eb6f69a9e2976849aa183f28812b4ea..fb290bc72702ee9f5064d0fefb9ea83830544d42 100644 (file)
@@ -1,11 +1,11 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer type="project">
-       <email>sci@gentoo.org</email>
-       <name>Gentoo Science Project</name>
-</maintainer>
-<longdescription lang="en">
+       <maintainer type="project">
+               <email>sci@gentoo.org</email>
+               <name>Gentoo Science Project</name>
+       </maintainer>
+       <longdescription lang="en">
   CXSparse is an extended version of CSparse, a sparse matrix package,
   with support for double or complex matrices, with int or long
   integers.