app-admin/webapp-config: Adds 1.55 ebuild to the tree
authorDevan Franchini <twitch153@gentoo.org>
Thu, 22 Jun 2017 23:31:18 +0000 (19:31 -0400)
committerDevan Franchini <twitch153@gentoo.org>
Thu, 22 Jun 2017 23:33:11 +0000 (19:33 -0400)
Package-Manager: Portage-2.3.6, Repoman-2.3.1

app-admin/webapp-config/Manifest
app-admin/webapp-config/webapp-config-1.55.ebuild [new file with mode: 0644]

index 4c6c0ac19339d7e2ecae8c01c286fe4cbd0e6e8c..49de5cd1bdf73f236671e74146eb8a0cf7695736 100644 (file)
@@ -1,3 +1,4 @@
 DIST webapp-config-1.52.tar.bz2 62951 SHA256 b8295bbc518f68f60913fe2ee9232d77f1a10e21fcddffb8c4370546ba96a2a5 SHA512 ec616067588e6ab306af067e70bab9d17961aa675f387ee67a2291235ce81638b49a784d9a6c31891b7c78a712f276c3e62c6681a5e496a52c7e6fe7753922ea WHIRLPOOL ca6484871e26acff6d14510a4a925672258f58c1c8c05c5207b78350b1cc787e29c6ea68c1af05b5c5aaebed12ce545e023f54acbdc7215678b30a2f14708eee
 DIST webapp-config-1.53.tar.bz2 63429 SHA256 4d45b1452feb730cc55bfdce686277183acfd64ab6aef5fab82992d1a508263d SHA512 7d2fc7197d537f2264c26b68b61e69273d2fcd3eec93657db54ba685c8383e7b8245cf05ed2ddd8b72453bf3fbf8f4bc4867e53d608331799df2e6162be14820 WHIRLPOOL f12ca0f3fcee31de6e2ead3cd3685fa32c697d258324bf40fc2bfc2f1787c4e7cbd7290bbb5f5523515bff29cb78bece35fcad390e419cf5dd619e5efdafc1dc
 DIST webapp-config-1.54.tar.bz2 58954 SHA256 7663c4f7ae0d4e7206e349f3bf79fed479c9971365363929f431c92ebd622d17 SHA512 fa61e88696eaed130575e5ae9a17ec827aa14aece359e5ba43fa723ad00083def22e44fb02d99fc5ba6000a5949c5ce7aecea9307d2bfae333e202ef111dcd31 WHIRLPOOL 417944147e0bdc7eb1575b10102230306f6c76652beeb0e2866d0fbe41b12bcdeb31421dd7551961db55f4fe4544ca5600c072cb74083621745c7c74fbfeec2e
+DIST webapp-config-1.55.tar.bz2 72583 SHA256 222c41ac71b2991b078352fb8d09a0d458ff30b9c9729a2429165835c38c564b SHA512 44294b276fd036908438cd984ebf70433639caa18d8330bab348433b4f39ea2c42c57fa8de4f0a6198f7875429a3ef9ebe61321c288d910f9be8b3414865f438 WHIRLPOOL 80d577e4398f6872129544221d58003beb5b5ce972c181a241ec96cfe0fe34975e7bef5a96acc40977320ad71cd4370ee58216c0517d78c1765f000a42d8ea56
diff --git a/app-admin/webapp-config/webapp-config-1.55.ebuild b/app-admin/webapp-config/webapp-config-1.55.ebuild
new file mode 100644 (file)
index 0000000..d1f94e2
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1 prefix
+
+SRC_URI="https://dev.gentoo.org/~twitch153/${PN}/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+portage"
+
+DEPEND="app-text/xmlto
+       !dev-python/configparser
+       sys-apps/gentoo-functions"
+RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+       eprefixify WebappConfig/eprefix.py config/webapp-config
+}
+
+python_compile_all() {
+       emake -C doc/
+}
+
+python_install() {
+       # According to this discussion:
+       # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+       # distutils does not provide for specifying two different script install
+       # locations. Since we only install one script here the following should
+       # be ok
+       distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       insinto /etc/vhosts
+       doins config/webapp-config
+
+       keepdir /usr/share/webapps
+       keepdir /var/db/webapps
+
+       dodoc AUTHORS
+       doman doc/*.[58]
+       dohtml doc/*.[58].html
+}
+
+python_test() {
+       PYTHONPATH="." "${PYTHON}" WebappConfig/tests/external.py \
+               || die "Testing failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       elog "Now that you have upgraded webapp-config, you **must** update your"
+       elog "config files in /etc/vhosts/webapp-config before you emerge any"
+       elog "packages that use webapp-config."
+}