dev-python/numba: Remove old
authorDavid Seifert <soap@gentoo.org>
Thu, 26 Dec 2019 14:36:08 +0000 (15:36 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 26 Dec 2019 14:36:08 +0000 (15:36 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/numba/Manifest
dev-python/numba/numba-0.27.0.ebuild [deleted file]
dev-python/numba/numba-0.35.0.ebuild [deleted file]

index 1ba1c70edada95611f90e8532e099a0b9b2b3e57..6cc4b9cbb0cd62539a48dff8c78c806d354252a2 100644 (file)
@@ -1,4 +1,2 @@
-DIST numba-0.27.0.tar.gz 1247144 BLAKE2B 42de6e0f7865efb597ed1dd3680eafc66906d5d9cc7a8b583847cdd12a936174af976933de5aa02859c2025b86f51da3d0148f89ecd35287caadd8da8fa8bb53 SHA512 3c84fa58bc5e84683b5e593b99f8c48cfc6e9fd0f41a2a18d8a4d9deba618cec1e764a0202bb71166cbeebf27b908044be29e3b183b01f31edc8e85c962df876
-DIST numba-0.35.0.tar.gz 1647189 BLAKE2B f0dfd6fe03e1a60b4d19f0f4d1b158d418686376f4317b7f4b5fa0734b35b6ce670661705f92994910a8b47bbd0689dca652f36cea1a2f9d5afa419ae1c8b5fd SHA512 48ee1e33e7ec1327a78c3485602e911f045df8b8dbb69da3004133e6da8cbb52388712b4aeffa1e41b83d20aaa88cc8c1202ef35aabbf3e0e04ad2875df789f0
 DIST numba-0.37.0.tar.gz 1734667 BLAKE2B 20fd765d226e6e71a0e94bbf8c6a605ef7b4cf8ba6e39667001051c642fb9b872540482e710e020c0fca6653d9ca4518ce82e48681613f28ac5b9e2346bece4f SHA512 83a4e5a28a43ed1cd6584ccd63aac38a928af48c424ed119bc86487f0a2bfb9875c34f6fe0a03446d8c8e9179be81f831200c12ff31edc22bc4741789095f861
 DIST numba-0.39.0.tar.gz 1782489 BLAKE2B 77a6afe587ce3ae0ccd782e329e626d63ab58b84a2aeb836710fc0c13dcc88e16ab36e7426c6d9ff88c6d5be854915128dc2868d7fa71511ec9c8eea9debffe7 SHA512 f9cabf39fea543495425ba326aad34a52d317ebef61e5b298588764214bb396ea43871d32875f0882a36909bb12fc2e3807c38b5fc60ff5d9e6dc9ccdd36bf6e
diff --git a/dev-python/numba/numba-0.27.0.ebuild b/dev-python/numba/numba-0.27.0.ebuild
deleted file mode 100644 (file)
index d17a5b2..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
-HOMEPAGE="http://numba.pydata.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/llvmlite-0.10[${PYTHON_USEDEP}]
-       >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python{2_7,3_3})
-       virtual/python-funcsigs[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? ( virtual/python-singledispatch[${PYTHON_USEDEP}] )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Delete intersphinx & entry to set sphinxjp.themecore, which is absent from portage, from conf.py
-PATCHES=( "${FILESDIR}"/${PN}-0.19.2-docbuild.patch )
-
-python_prepare_all() {
-       # Re-set them of doc build to one provided by sphinx
-       if has_version ">=dev-python/sphinx-1.3.1"; then
-               sed -e 's:basicstrap:classic:' -i docs/source/conf.py || die
-       else
-               sed -e 's:basicstrap:default:' -i docs/source/conf.py || die
-       fi
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       if ! python_is_python3; then
-               local CFLAGS="${CFLAGS} -fno-strict-aliasing"
-               export CFLAGS
-       fi
-       distutils-r1_python_compile
-}
-
-python_compile_all() {
-       use doc && emake -C docs/ html
-}
-
-python_test() {
-       cd "${BUILD_DIR}"/lib* || die
-       ${EPYTHON} -c "import numba; numba.test()" || die
-}
-
-python_install_all() {
-       # doc needs obsolete sphinxjp package
-#      use doc && dodoc docs/Numba.pdf
-       use examples && local EXAMPLES=( examples/. )
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/numba/numba-0.35.0.ebuild b/dev-python/numba/numba-0.35.0.ebuild
deleted file mode 100644 (file)
index 9f39737..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
-HOMEPAGE="http://numba.pydata.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/llvmlite-0.19[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
-       virtual/python-enum34[${PYTHON_USEDEP}]
-       virtual/python-funcsigs[${PYTHON_USEDEP}]
-       virtual/python-singledispatch[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_test() {
-       cd "${BUILD_DIR}"/lib* || die
-       ${EPYTHON} -c "import numba; numba.test()" || die
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-}