sys-devel/clang-common: Port 9+ to llvm.org.eclass
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 17:37:42 +0000 (18:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 Nov 2019 11:46:13 +0000 (12:46 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
sys-devel/clang-common/clang-common-9.0.0.ebuild
sys-devel/clang-common/clang-common-9.0.1.9999.ebuild

index 6b707e3d41ff831de20bc1586102b61e83fbb40b..d1bfe71d2f8024bd603c620f053bd72004885f79 100644 (file)
@@ -3,13 +3,13 @@
 
 EAPI=7
 
-inherit bash-completion-r1 git-r3
+inherit bash-completion-r1 llvm.org
 
 DESCRIPTION="Common files shared between multiple slots of clang"
 HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-S=${WORKDIR}/${P}/clang
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -18,15 +18,6 @@ IUSE=""
 
 PDEPEND="sys-devel/clang:*"
 
-src_unpack() {
-       git-r3_fetch
-       git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
 src_install() {
-       newbashcomp utils/bash-autocomplete.sh clang
+       newbashcomp bash-autocomplete.sh clang
 }
index 609bdcde4cc0cf30924f313eb76cc11589c85fca..3fc7a056a923cd2839bcace8485777b9fe7909da 100644 (file)
@@ -3,13 +3,13 @@
 
 EAPI=7
 
-inherit bash-completion-r1
+inherit bash-completion-r1 llvm.org
 
-MY_P=cfe-${PV/_/}.src
 DESCRIPTION="Common files shared between multiple slots of clang"
 HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
-S=${WORKDIR}/${MY_P}
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -18,15 +18,6 @@ IUSE=""
 
 PDEPEND="sys-devel/clang:*"
 
-src_unpack() {
-       einfo "Unpacking parts of ${MY_P}.tar.xz ..."
-       tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/bash-autocomplete.sh" || die
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
 src_install() {
-       newbashcomp utils/bash-autocomplete.sh clang
+       newbashcomp bash-autocomplete.sh clang
 }
index eecb0ff749dccbd35b09198b8c697d782243069a..d1bfe71d2f8024bd603c620f053bd72004885f79 100644 (file)
@@ -3,14 +3,13 @@
 
 EAPI=7
 
-inherit bash-completion-r1 git-r3
+inherit bash-completion-r1 llvm.org
 
 DESCRIPTION="Common files shared between multiple slots of clang"
 HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-EGIT_BRANCH="release/9.x"
-S=${WORKDIR}/${P}/clang
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -19,15 +18,6 @@ IUSE=""
 
 PDEPEND="sys-devel/clang:*"
 
-src_unpack() {
-       git-r3_fetch
-       git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
 src_install() {
-       newbashcomp utils/bash-autocomplete.sh clang
+       newbashcomp bash-autocomplete.sh clang
 }