dev-php/pecl-xdiff: add PHP 7.3 support
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 12:07:52 +0000 (14:07 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 14:07:47 +0000 (16:07 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/pecl-xdiff/pecl-xdiff-2.0.1-r2.ebuild

index 5bc4d42fc327fb06ddca2a9953f710125a3e2386..f8bd2e2c845ced13adf51918238abe98d2abaa5a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -7,11 +7,11 @@ PHP_EXT_NAME="xdiff"
 PHP_EXT_PECL_PKG="xdiff"
 DOCS=( README.API )
 
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
 
 inherit php-ext-pecl-r3
 
-USE_PHP="php7-0 php7-1 php7-2"
+USE_PHP="php7-0 php7-1 php7-2 php7-3"
 
 KEYWORDS="~amd64 ~x86"
 
@@ -23,11 +23,12 @@ DEPEND="
        php_targets_php7-0? ( dev-libs/libxdiff )
        php_targets_php7-1? ( dev-libs/libxdiff )
        php_targets_php7-2? ( dev-libs/libxdiff )
+       php_targets_php7-3? ( dev-libs/libxdiff )
 "
 RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-xdiff:0[php_targets_php5-6] )"
 
 src_prepare() {
-       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                php-ext-source-r3_src_prepare
        else
                eapply_user
@@ -35,14 +36,14 @@ src_prepare() {
 }
 
 src_configure() {
-       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                local PHP_EXT_ECONF_ARGS=()
                php-ext-source-r3_src_configure
        fi
 }
 
 src_install() {
-       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+       if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                php-ext-pecl-r3_src_install
        fi
 }