Revision bump, with patch to fix level9 compilation. Closes bug #163374. Wiped out...
authorMichele Noberasco <s4t4n@gentoo.org>
Fri, 26 Jan 2007 10:15:07 +0000 (10:15 +0000)
committerMichele Noberasco <s4t4n@gentoo.org>
Fri, 26 Jan 2007 10:15:07 +0000 (10:15 +0000)
Package-Manager: portage-2.1.1-r2

games-engines/gargoyle/ChangeLog
games-engines/gargoyle/files/digest-gargoyle-20060917-r1 [new file with mode: 0644]
games-engines/gargoyle/files/level9-compilation-fix-20060917.patch [new file with mode: 0644]
games-engines/gargoyle/gargoyle-20060917-r1.ebuild [new file with mode: 0644]

index 27a41b6f3e7a7f8ebad9bdde31b6df9fc301790e..4460f48b1547a5b745fb4e1636e799fe18937dd9 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for games-engines/gargoyle
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.5 2007/01/22 10:59:52 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.6 2007/01/26 10:15:07 s4t4n Exp $
+
+*gargoyle-20060917-r1 (26 Jan 2007)
+
+  26 Jan 2007; Michele Noberasco <s4t4n@gentoo.org> gargoyle-20060917-r1.ebuild:
+  Revision bump, with patch to fix level9 interpreter compilation. Closes bug #163374.
+  gargoyle-20060917.ebuild:
+  Wiped out previous revision.
 
 *gargoyle-20060917 (22 Jan 2007)
 
diff --git a/games-engines/gargoyle/files/digest-gargoyle-20060917-r1 b/games-engines/gargoyle/files/digest-gargoyle-20060917-r1
new file mode 100644 (file)
index 0000000..fb141c1
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 19467db0e693c31810153ca8aaf7f915 gargoyle-2006-09-17-source.zip 9714916
+RMD160 86e832323f8da96004460c7fa5b1054717817884 gargoyle-2006-09-17-source.zip 9714916
+SHA256 3a39e8e8809a8d942bb5ae71b8f64e4f4f4ecbf2cd1e7de0ed40fd58ea2f7ce0 gargoyle-2006-09-17-source.zip 9714916
diff --git a/games-engines/gargoyle/files/level9-compilation-fix-20060917.patch b/games-engines/gargoyle/files/level9-compilation-fix-20060917.patch
new file mode 100644 (file)
index 0000000..7ab367d
--- /dev/null
@@ -0,0 +1,60 @@
+Only in gargoyle/terps/level9: .level9.c.swp
+diff -rU2 gargoyle-orig/terps/level9/level9.c gargoyle/terps/level9/level9.c
+--- gargoyle-orig/terps/level9/level9.c        2007-01-22 20:50:44.000000000 -0330
++++ gargoyle/terps/level9/level9.c     2007-01-22 20:51:47.000000000 -0330
+@@ -116,5 +116,5 @@
+ GameState CheatWorkspace;\r
\r
+-int reflectflag,scale,gintcolour,option;\r
++int reflectflag,scale,gintcolour,zoption;\r
+ int l9textmode=0,drawx=0,drawy=0,screencalled=0,showtitle=1;\r
+ L9BYTE *gfxa5=NULL;\r
+@@ -2810,9 +2810,9 @@
+ #ifdef L9DEBUG\r
+       printf("gfx - sdraw (%d,%d) (%d,%d) colours %d,%d",\r
+-              x1,y1,drawx,drawy,gintcolour&3,option&3);\r
++              x1,y1,drawx,drawy,gintcolour&3,zoption&3);\r
+ #endif\r
\r
+       os_drawline(scalex(x1),scaley(y1),scalex(drawx),scaley(drawy),\r
+-              gintcolour&3,option&3);\r
++              gintcolour&3,zoption&3);\r
+ }\r
\r
+@@ -2884,9 +2884,9 @@
+ #ifdef L9DEBUG\r
+       printf("gfx - draw (%d,%d) (%d,%d) colours %d,%d",\r
+-              x1,y1,drawx,drawy,gintcolour&3,option&3);\r
++              x1,y1,drawx,drawy,gintcolour&3,zoption&3);\r
+ #endif\r
\r
+       os_drawline(scalex(x1),scaley(y1),scalex(drawx),scaley(drawy),\r
+-              gintcolour&3,option&3);\r
++              gintcolour&3,zoption&3);\r
+ }\r
\r
+@@ -2955,8 +2955,8 @@
\r
+ #ifdef L9DEBUG\r
+-      printf("gfx - gintfill (%d,%d) colours %d,%d",drawx,drawy,d7&3,option&3);\r
++      printf("gfx - gintfill (%d,%d) colours %d,%d",drawx,drawy,d7&3,zoption&3);\r
+ #endif\r
\r
+-      os_fill(scalex(drawx),scaley(drawy),d7&3,option&3);\r
++      os_fill(scalex(drawx),scaley(drawy),d7&3,zoption&3);\r
+ }\r
\r
+@@ -3022,5 +3022,5 @@
+               d0 = (d0&3)|0x80;\r
+ /* optend */\r
+-      option = d0;\r
++      zoption = d0;\r
+ }\r
\r
+@@ -3115,5 +3115,5 @@
+ /* gintinit */\r
+               gintcolour = 3;\r
+-              option = 0x80;\r
++              zoption = 0x80;\r
+               reflectflag = 0;\r
+               drawx = 0x1400;\r
diff --git a/games-engines/gargoyle/gargoyle-20060917-r1.ebuild b/games-engines/gargoyle/gargoyle-20060917-r1.ebuild
new file mode 100644 (file)
index 0000000..01f9cf5
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-20060917-r1.ebuild,v 1.1 2007/01/26 10:15:07 s4t4n Exp $
+
+inherit eutils
+
+MY_PV="2006-09-17"
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="Beautified Glk library and interactive fiction multi-interpreter"
+HOMEPAGE="http://ccxvii.net/gargoyle/"
+SRC_URI="http://ccxvii.net/gargoyle/download/${MY_P}-source.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/freetype-2.1.9-r1
+       >=x11-libs/gtk+-2.10.6
+       >=dev-libs/glib-2.12.4-r1
+       >=media-libs/jpeg-6b-r5
+       >=media-libs/libpng-1.2.8
+       >=sys-libs/zlib-1.2.3
+       >=media-libs/fmod-3.74
+       >=media-libs/sdl-sound-1.0.1-r1
+       >=media-libs/sdl-mixer-1.2.7"
+
+DEPEND="${RDEPEND}
+       >=dev-util/jam-2.5-r3
+       app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       #Fix file named
+       epatch "${FILESDIR}"/filename-friendliness-${PV}.patch
+
+       #Fix level9 compilation
+       epatch "${FILESDIR}"/level9-compilation-fix-${PV}.patch
+
+       #Fix gtk+ detection
+       sed -i \
+               -e 's/"pkg-config freetype2 gtk+"/"pkg-config freetype2 gtk+-2.0"/' \
+               Jamrules \
+               || die "sed failed"
+}
+
+src_compile() {
+       jam || die "jam failed"
+}
+
+src_install() {
+       dodoc garglk/TODO licenses/*
+       insinto /etc
+       newins garglk/garglk.ini garglk.ini
+
+       #Should to copy garglk/garglk.ini to /etc/, but I don't know the syntax
+
+       cd build/linux.release
+       dolib garglk/libgarglk.so
+       dobin \
+               advsys/gargoyle-advsys agility/gargoyle-agility alan2/gargoyle-alan2 \
+               alan3/gargoyle-alan3 garglk/gargoyle git/gargoyle-git \
+               hugo/gargoyle-hugo level9/gargoyle-level9 scare/gargoyle-scare \
+               tads/gargoyle-tadsr frotz/gargoyle-frotz magnetic/gargoyle-magnetic
+}