sci-geosciences/merkaartor: Add USE=webengine, drop Qt4 support
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 2 Mar 2017 23:27:03 +0000 (00:27 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 3 Mar 2017 00:14:07 +0000 (01:14 +0100)
Qt4 is deprecated upstream.

Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-geosciences/merkaartor/merkaartor-9999.ebuild
sci-geosciences/merkaartor/metadata.xml

index dfce8ca18ad30f227607cd208edf58da32c3240f..5e16f21d97d636c9829a222b643e91269235f99c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -7,7 +7,7 @@ PLOCALES="ar cs de en es et fr hr hu id_ID it ja nl pl pt_BR pt ru sk sv uk vi z
 
 inherit fdo-mime gnome2-utils git-r3 l10n qmake-utils
 
-DESCRIPTION="Qt based map editor for the openstreetmap.org project"
+DESCRIPTION="Qt based map editor for the openstreetmap.org project"
 HOMEPAGE="http://www.merkaartor.be https://github.com/openstreetmap/merkaartor"
 SRC_URI=""
 EGIT_REPO_URI="https://github.com/openstreetmap/merkaartor.git"
@@ -15,39 +15,27 @@ EGIT_REPO_URI="https://github.com/openstreetmap/merkaartor.git"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="debug exif gps libproxy qrcode qt5"
-
-REQUIRED_USE="qrcode? ( !qt5 )"
+IUSE="debug exif gps libproxy webengine"
 
 RDEPEND="
-       !qt5? (
-               dev-qt/qtcore:4
-               dev-qt/qtgui:4
-               dev-qt/qtsingleapplication[qt4]
-               dev-qt/qtsvg:4
-               dev-qt/qtwebkit:4
-       )
-       qt5? (
-               dev-qt/qtconcurrent:5
-               dev-qt/qtcore:5
-               dev-qt/qtgui:5
-               dev-qt/qtprintsupport:5
-               dev-qt/qtsvg:5
-               dev-qt/qtwebkit:5
-               dev-qt/qtwidgets:5
-               dev-qt/qtxml:5
-       )
-       dev-qt/qtsingleapplication[X,qt5?]
-       >=sci-libs/gdal-1.6.0
-       >=sci-libs/proj-4.6
+       dev-qt/qtconcurrent:5
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtprintsupport:5
+       dev-qt/qtsingleapplication[X,qt5]
+       dev-qt/qtsvg:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtxml:5
+       sci-libs/gdal
+       sci-libs/proj
        sys-libs/zlib
        exif? ( media-gfx/exiv2:= )
        gps? ( >=sci-geosciences/gpsd-3.13[cxx] )
        libproxy? ( net-libs/libproxy )
-       qrcode? ( media-gfx/zbar[qt4] )
+       webengine? ( dev-qt/qtwebengine:5 )
 "
 DEPEND="${RDEPEND}
-       qt5? ( dev-qt/linguist-tools:5 )
+       dev-qt/linguist-tools:5
        virtual/pkgconfig
 "
 
@@ -67,11 +55,7 @@ src_prepare() {
 
        if [[ -n "$(l10n_get_locales)" ]]; then
                l10n_for_each_disabled_locale_do my_rm_loc
-               if use qt5 ; then
-                       $(qt5_get_bindir)/lrelease src/src.pro || die
-               else
-                       $(qt4_get_bindir)/lrelease src/src.pro || die
-               fi
+               $(qt5_get_bindir)/lrelease src/src.pro || die
        fi
 
        # build system expects to be building from git
@@ -82,33 +66,18 @@ src_prepare() {
 
 src_configure() {
        # TRANSDIR_SYSTEM is for bug #385671
-       if use qt5 ; then
-               eqmake5 \
+       eqmake5 \
                PREFIX="${ED}usr" \
                LIBDIR="${ED}usr/$(get_libdir)" \
                TRANSDIR_MERKAARTOR="${ED}usr/share/${PN}/translations" \
                TRANSDIR_SYSTEM="${EPREFIX}/usr/share/qt5/translations" \
                SYSTEM_QTSA=1 \
-               NODEBUG="$(usex debug '0' '1')" \
-               GEOIMAGE="$(usex exif '1' '0')" \
-               GPSDLIB="$(usex gps '1' '0')" \
-               LIBPROXY="$(usex libproxy '1' '0')" \
-               ZBAR="$(usex qrcode '1' '0')" \
+               NODEBUG=$(usex debug 0 1) \
+               GEOIMAGE=$(usex exif 1 0) \
+               GPSDLIB=$(usex gps 1 0) \
+               LIBPROXY=$(usex libproxy 1 0) \
+               USEWEBENGINE=$(usex webengine 1 0) \
                Merkaartor.pro
-       else
-               eqmake4 \
-               PREFIX="${ED}usr" \
-               LIBDIR="${ED}usr/$(get_libdir)" \
-               TRANSDIR_MERKAARTOR="${ED}usr/share/${PN}/translations" \
-               TRANSDIR_SYSTEM="${EPREFIX}/usr/share/qt4/translations" \
-               SYSTEM_QTSA=1 \
-               NODEBUG="$(usex debug '0' '1')" \
-               GEOIMAGE="$(usex exif '1' '0')" \
-               GPSDLIB="$(usex gps '1' '0')" \
-               LIBPROXY="$(usex libproxy '1' '0')" \
-               ZBAR="$(usex qrcode '1' '0')" \
-               Merkaartor.pro
-       fi
 }
 
 pkg_preinst() {
index ac3993f6272343ab1c6fa3ad7110b40ab15d357f..0182aec4c095afb95ba4cdc0ffb6a4586dc57c87 100644 (file)
@@ -8,6 +8,7 @@
        <use>
                <flag name="libproxy">Use <pkg>net-libs/libproxy</pkg> for getting the HTTP/HTTPS/SOCKS proxy configuration</flag>
                <flag name="qrcode">Enable QR code scanning with <pkg>media-gfx/zbar</pkg></flag>
+               <flag name="webengine">Enable <pkg>dev-qt/qtwebengine</pkg> in some plugins</flag>
        </use>
        <upstream>
                <remote-id type="github">openstreetmap/merkaartor</remote-id>