dev-python/snakeoil: remove old
authorTim Harder <radhermit@gentoo.org>
Fri, 24 Apr 2020 02:32:17 +0000 (20:32 -0600)
committerTim Harder <radhermit@gentoo.org>
Fri, 24 Apr 2020 02:32:17 +0000 (20:32 -0600)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
dev-python/snakeoil/Manifest
dev-python/snakeoil/snakeoil-0.7.5.ebuild [deleted file]

index 5943ba9fb89d48f8796377ca46b40f214cebd69c..aab9191ed99917abd134262b6367971d249da73b 100644 (file)
@@ -1,2 +1 @@
-DIST snakeoil-0.7.5.tar.gz 303270 BLAKE2B 66d00cf50c8efd73d765904b9c7e8ba725caef9608e68f5707ddc09358507fe64214af73b333ec5bee2ef950d8dbad474cb5d9e4412757bc3c82d75909f6fc23 SHA512 b9f6efce2e3f5df83248b1faa84493aa11d8a08935e3991a56daace96e0de39dd5c7d25a69a4394f7ba163de78ed56a2619ef64c33114128fc02052d676a86a5
 DIST snakeoil-0.8.8.tar.gz 296519 BLAKE2B 5a5f6326d01874b46a5cb85f5370217f4f3dfd5743679280f1f59737567cd5d79deb945be847fd3cd47ff0ed67cc836d2a3e53c4aefbe8080da767f380295538 SHA512 ea1ff6ea45c9f5fc3bc539cc65031050093cc1fbdda869b7160b286dcf3233577ca297ab55ee3d7ee4253c5485f9e956e14ee2a97bfb88680811d1b8af6cd62d
diff --git a/dev-python/snakeoil/snakeoil-0.7.5.ebuild b/dev-python/snakeoil/snakeoil-0.7.5.ebuild
deleted file mode 100644 (file)
index 16d993d..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
-       EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
-       inherit git-r3
-else
-       KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
-       SRC_URI="https://github.com/pkgcore/snakeoil/releases/download/v${PV}/${P}.tar.gz"
-fi
-
-DESCRIPTION="misc common functionality and useful optimizations"
-HOMEPAGE="https://github.com/pkgcore/snakeoil"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-[[ ${PV} == 9999 ]] && DEPEND+=" $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python3*')"
-
-python_configure_all() {
-       # disable snakeoil 2to3 caching
-       unset PY2TO3_CACHEDIR
-}
-
-python_test() {
-       esetup.py test
-}