dev-lang/tcl: Remove SLOT 8.5
authorTupone Alfredo <tupone@gentoo.org>
Tue, 29 Oct 2019 07:35:57 +0000 (08:35 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Tue, 29 Oct 2019 07:35:57 +0000 (08:35 +0100)
Closes: https://bugs.gentoo.org/697828
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-lang/tcl/tcl-8.5.17-r100.ebuild [deleted file]
dev-lang/tcl/tcl-8.5.17-r101.ebuild [deleted file]

diff --git a/dev-lang/tcl/tcl-8.5.17-r100.ebuild b/dev-lang/tcl/tcl-8.5.17-r100.ebuild
deleted file mode 100644 (file)
index d346430..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# this ebuild is only for the libtcl8.5.so SONAME for ABI compat
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic multilib toolchain-funcs versionator multilib-minimal
-
-MY_P="${PN}${PV/_beta/b}"
-
-DESCRIPTION="Tool Command Language"
-HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
-
-LICENSE="tcltk"
-SLOT="8.5"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
-IUSE="debug threads"
-
-RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
-       !=dev-lang/tcl-8.5*:0"
-DEPEND="${RDEPEND}
-       "
-
-SPARENT="${WORKDIR}/${MY_P}"
-S="${SPARENT}"/unix
-
-DOCS=()
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-8.5.13-multilib.patch
-
-       # Bug 125971
-       epatch "${FILESDIR}"/${PN}-8.5.14-conf.patch
-
-       # workaround stack check issues, bug #280934
-       use hppa && append-cflags "-DTCL_NO_STACK_CHECK=1"
-
-       tc-export CC
-
-       sed \
-               -e '/chmod/s:555:755:g' \
-               -i Makefile.in || die
-
-       eautoconf
-       multilib_copy_sources
-}
-
-multilib_src_configure() {
-       # We went ahead and deleted the whole compat/ subdir which means
-       # the configure tests to detect broken versions need to pass (else
-       # we'll fail to build).  This comes up when cross-compiling, but
-       # might as well get a minor configure speed up normally.
-       export ac_cv_func_memcmp_working="yes"
-       export tcl_cv_str{str,toul,tod}_unbroken="ok"
-       export tcl_cv_strtod_buggy="no"
-
-       econf \
-               $(use_enable threads) \
-               $(use_enable debug symbols)
-}
-
-multilib_src_install() {
-       dolib.so libtcl8.5.so
-       dolib.a libtclstub8.5.a
-
-       #short version number
-       local v1=$(get_version_component_range 1-2)
-       local mylibdir=$(get_libdir)
-
-       # fix the tclConfig.sh to eliminate refs to the build directory
-       # and drop unnecessary -L inclusion to default system libdir
-
-       sed \
-               -e "/^TCL_BUILD_LIB_SPEC=/s:-L$(pwd) *::g" \
-               -e "/^TCL_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
-               -e "/^TCL_SRC_DIR=/s:${SPARENT}:${EPREFIX}/usr/${mylibdir}/tcl${v1}/include:g" \
-               -e "/^TCL_BUILD_STUB_LIB_SPEC=/s:-L$(pwd) *::g" \
-               -e "/^TCL_STUB_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
-               -e "/^TCL_BUILD_STUB_LIB_PATH=/s:$(pwd):${EPREFIX}/usr/${mylibdir}:g" \
-               -e "/^TCL_LIB_FILE=/s:'libtcl${v1}..TCL_DBGX..so':\"libtcl${v1}\$\{TCL_DBGX\}.so\":g" \
-               -i tclConfig.sh || die
-       if use prefix && [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
-               sed \
-                       -e "/^TCL_CC_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|g" \
-                       -e "/^TCL_LD_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|" \
-                       -i tclConfig.sh || die
-       fi
-
-       insinto /usr/${mylibdir}/tcl${v1}
-       doins tclConfig.sh
-}
diff --git a/dev-lang/tcl/tcl-8.5.17-r101.ebuild b/dev-lang/tcl/tcl-8.5.17-r101.ebuild
deleted file mode 100644 (file)
index 8edd0ea..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# this ebuild is only for the libtcl8.5.so SONAME for ABI compat
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic multilib toolchain-funcs versionator multilib-minimal
-
-MY_P="${PN}${PV/_beta/b}"
-
-DESCRIPTION="Tool Command Language"
-HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
-
-LICENSE="tcltk"
-SLOT="8.5"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
-IUSE="debug threads"
-
-RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
-       !=dev-lang/tcl-8.5*:0"
-DEPEND="${RDEPEND}
-       "
-
-SPARENT="${WORKDIR}/${MY_P}"
-S="${SPARENT}"/unix
-
-DOCS=()
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-8.5.13-multilib.patch
-
-       # Bug 125971
-       epatch "${FILESDIR}"/${PN}-8.5.14-conf.patch
-
-       # Bug 648570
-       epatch "${FILESDIR}"/${PN}-8.6.8-libieee.patch
-
-       # workaround stack check issues, bug #280934
-       use hppa && append-cflags "-DTCL_NO_STACK_CHECK=1"
-
-       tc-export CC
-
-       sed \
-               -e '/chmod/s:555:755:g' \
-               -i Makefile.in || die
-
-       eautoconf
-       multilib_copy_sources
-}
-
-multilib_src_configure() {
-       # We went ahead and deleted the whole compat/ subdir which means
-       # the configure tests to detect broken versions need to pass (else
-       # we'll fail to build).  This comes up when cross-compiling, but
-       # might as well get a minor configure speed up normally.
-       export ac_cv_func_memcmp_working="yes"
-       export tcl_cv_str{str,toul,tod}_unbroken="ok"
-       export tcl_cv_strtod_buggy="no"
-
-       econf \
-               $(use_enable threads) \
-               $(use_enable debug symbols)
-}
-
-multilib_src_install() {
-       dolib.so libtcl8.5.so
-       dolib.a libtclstub8.5.a
-
-       #short version number
-       local v1=$(get_version_component_range 1-2)
-       local mylibdir=$(get_libdir)
-
-       # fix the tclConfig.sh to eliminate refs to the build directory
-       # and drop unnecessary -L inclusion to default system libdir
-
-       sed \
-               -e "/^TCL_BUILD_LIB_SPEC=/s:-L$(pwd) *::g" \
-               -e "/^TCL_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
-               -e "/^TCL_SRC_DIR=/s:${SPARENT}:${EPREFIX}/usr/${mylibdir}/tcl${v1}/include:g" \
-               -e "/^TCL_BUILD_STUB_LIB_SPEC=/s:-L$(pwd) *::g" \
-               -e "/^TCL_STUB_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
-               -e "/^TCL_BUILD_STUB_LIB_PATH=/s:$(pwd):${EPREFIX}/usr/${mylibdir}:g" \
-               -e "/^TCL_LIB_FILE=/s:'libtcl${v1}..TCL_DBGX..so':\"libtcl${v1}\$\{TCL_DBGX\}.so\":g" \
-               -i tclConfig.sh || die
-       if use prefix && [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
-               sed \
-                       -e "/^TCL_CC_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|g" \
-                       -e "/^TCL_LD_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|" \
-                       -i tclConfig.sh || die
-       fi
-
-       insinto /usr/${mylibdir}/tcl${v1}
-       doins tclConfig.sh
-}