net-misc/owncloud-client: 2.6.0.13018 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Thu, 14 Nov 2019 08:02:41 +0000 (09:02 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Thu, 14 Nov 2019 08:07:22 +0000 (09:07 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
net-misc/owncloud-client/Manifest
net-misc/owncloud-client/owncloud-client-2.6.0.13018.ebuild [new file with mode: 0644]

index f7b659c02e64b2b0cf88d747f95e631c41163759..b57e58fedd11cd7f16671b87de409fb515e62074 100644 (file)
@@ -1,2 +1,3 @@
 DIST owncloudclient-2.5.3.11470.tar.xz 16719780 BLAKE2B 0c10d95ef2d851ba3f728dfe1c55c4143cf9d1542c1f9e77904324f598ecbfa29e54119d12ebef78b8eafa1188e7359ce11d01034ff34a55a80d31d1d3b1db35 SHA512 331d8e8e71d64cf9c958f9391001c6fdff45795e7caad2ce7bf6802c4f0959adf694712cd298fb8702cd4e93577282957cabc61ccc5f4f3a57edc9ddf1c7c2a0
 DIST owncloudclient-2.5.4.11654.tar.xz 16720764 BLAKE2B f970e3ed5fbe465f93e9c4f4c2106604a08ada765f8692e1287878b7deb44ac92c53608f34b24a9c913510a5625c4e980c9ac2646689700e38e78822d3e98d21 SHA512 70b687d7ace4d1335388ebf60bf65137943ff0cadfefdcaffb09539c656889233100033f28db7d03f3d48f4b956aeed476bb458f8ef16ac5461287cf02e226d9
+DIST owncloudclient-2.6.0.13018.tar.xz 17311396 BLAKE2B b0c76b2fea51ca9e71f918ada2b99ce20b9b62494c41608e804c4ca0c8aafe59897fea31d28bed1ec61feefca4b4b6e783c6fa777ea56524e7c18d1a460ab954 SHA512 b8eb9dc6f9c061a74fee3f31926a3fb7f5093277955fe327d1169c84f929d1e1ad8da472a7098c1c10399f395c6bfc3b2684cf4c85cddc5e45b733abfb8e4046
diff --git a/net-misc/owncloud-client/owncloud-client-2.6.0.13018.ebuild b/net-misc/owncloud-client/owncloud-client-2.6.0.13018.ebuild
new file mode 100644 (file)
index 0000000..37f3df0
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Synchronize files from ownCloud Server with your computer"
+HOMEPAGE="https://owncloud.org/"
+SRC_URI="https://download.owncloud.com/desktop/stable/${P/-}.tar.xz"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc dolphin nautilus shibboleth test"
+
+COMMON_DEPEND=">=dev-db/sqlite-3.4:3
+       dev-libs/qtkeychain[qt5(+)]
+       dev-qt/qtconcurrent:5
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5[ssl]
+       dev-qt/qtsql:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtxml:5
+       sys-fs/inotify-tools
+       dolphin? (
+               kde-frameworks/kcoreaddons:5
+               kde-frameworks/kio:5
+       )
+       nautilus? ( dev-python/nautilus-python )
+       shibboleth? ( dev-qt/qtwebkit:5 )"
+
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+       dev-qt/linguist-tools:5
+       doc? (
+               dev-python/sphinx
+               dev-tex/latexmk
+               dev-texlive/texlive-latexextra
+               virtual/latex-base
+       )
+       dolphin? ( kde-frameworks/extra-cmake-modules )
+       test? (
+               dev-util/cmocka
+               dev-qt/qttest:5
+       )"
+
+S=${WORKDIR}/${P/-}
+
+src_prepare() {
+       # Keep tests in ${T}
+       sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
+
+       if ! use nautilus; then
+               pushd shell_integration > /dev/null || die
+               cmake_comment_add_subdirectory nautilus
+               popd > /dev/null || die
+       fi
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+               -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+               -DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=$(usex !doc)
+               -DCMAKE_DISABLE_FIND_PACKAGE_KF5=$(usex !dolphin)
+               -DNO_SHIBBOLETH=$(usex !shibboleth)
+               -DUNIT_TESTING=$(usex test)
+       )
+
+       cmake-utils_src_configure
+}
+
+pkg_postinst() {
+       if ! use doc ; then
+               elog "Documentation and man pages not installed"
+               elog "Enable doc USE-flag to generate them"
+       fi
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}