sci-libs/hypre: drop ancient versions
authorMatthias Maier <tamiko@gentoo.org>
Thu, 14 Nov 2019 05:48:18 +0000 (23:48 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Thu, 14 Nov 2019 06:01:37 +0000 (00:01 -0600)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
sci-libs/hypre/Manifest
sci-libs/hypre/hypre-2.11.1.ebuild [deleted file]
sci-libs/hypre/hypre-2.11.2.ebuild [deleted file]
sci-libs/hypre/hypre-2.9.0b.ebuild [deleted file]

index e9668ec51f77dd84f74966b19f56223bd01b7bc7..37a480f3de3821a2a3feb8e0c859a93e5280618e 100644 (file)
@@ -1,4 +1 @@
-DIST hypre-2.11.1.tar.gz 8054149 BLAKE2B 207d382b08ac67e09d55e323b86f84a0a7247baf21275c8774bf555c99401aa28f2ae6d4010a63d0c299a702a7b93a85ea98aed51ea5c8c8b31e4587760895d1 SHA512 4266c1b5225bcc97781246475100382f4929d7c918c854570a36b90602e8f111a4893cd1c93b95c68305c851898b970dd92ac173efe9211be5bb914d3c3c5d83
-DIST hypre-2.11.2.tar.gz 8077407 BLAKE2B d51a40d015f03757425da1fbc113a2647c267d1d47bebe343f2cd84983349cdbdb0e5b51a3c253edcab3d54f352158f0e263afcce592157b64202af471d642c6 SHA512 a06321028121e5420fa944ce4fae5f9b96e6021ec2802e68ec3c349f19a20543ed7eff774a4735666c5807ce124eb571b3f86757c67e91faa1c683c3f657469f
 DIST hypre-2.14.0.tar.gz 7312329 BLAKE2B 93de48bdd05c383c74fb1b3b25ddcd5830be099aa7557262547932e17eba524c25ff69ff94d10f29ffdabfef9c05281fd485a7c9b999141f2488ae4fc0238736 SHA512 c7b59fb7ab1cc906e339fcc00603898e44234a65aa74600f740bc825aa94aa66ff0cbd4bd4b7f339c0d28ff5bd9494f15b57f2017a22348fee14b4e8333f1e6c
-DIST hypre-2.9.0b.tar.gz 9053035 BLAKE2B 1bde86f88545d24617673a0c0c8c7458399bd7220a0ffe25ab4c9772e1c802c9b51ceaf716e843e236df1fd673bbd171642726590efdbb100821c3d3e54bacd7 SHA512 6856f2c80eaf669258d73a36a59c0fd0f43e20a5b2e633b6aefbccf41f5217ea821a6201dadc0de2b17a039ba9f53d98031f0b091e3db552cc5251a4f766acb8
diff --git a/sci-libs/hypre/hypre-2.11.1.ebuild b/sci-libs/hypre/hypre-2.11.1.ebuild
deleted file mode 100644 (file)
index f6aa3e5..0000000
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-
-inherit cmake-utils fortran-2 toolchain-funcs flag-o-matic
-
-DESCRIPTION="Parallel matrix preconditioners library"
-HOMEPAGE="https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods"
-SRC_URI="${HOMEPAGE}/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc examples fei fortran int64 openmp mpi"
-
-RDEPEND="
-       sci-libs/superlu:=
-       virtual/blas
-       virtual/lapack
-       mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
-DOCS=( CHANGELOG COPYRIGHT README )
-
-# 2.11.1: fei and mli wrappers still buggy with big integers
-REQUIRED_USE="int64? ( !fei )"
-
-pkg_pretend() {
-       [[ ${MERGE_TYPE} != binary ]] &&\
-               use openmp && [[ $(tc-getCC)$ == *gcc* ]] && tc-check-openmp
-}
-
-pkg_setup() {
-       if [[ ${MERGE_TYPE} != binary ]] && \
-                  use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp ; then
-               ewarn "You are using a non capable gcc compiler ( < 4.2 ? )"
-               die "Need an OpenMP capable compiler"
-       fi
-}
-
-src_prepare() {
-       default
-       # link with system superlu and propagate LDFLAGS
-       sed -e "s:@LIBS@:@LIBS@ $($(tc-getPKG_CONFIG) --libs superlu):" \
-               -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
-               -i src/config/Makefile.config.in || die
-       sed -e '/HYPRE_ARCH/s: = :=:g' \
-               -i src/configure || die
-       # link with system blas and lapack
-       sed -e '/^BLASFILES/d' \
-               -e '/^LAPACKFILES/d' \
-               -i src/lib/Makefile || die
-}
-
-src_configure() {
-       tc-export CC CXX
-       append-flags -Dhypre_dgesvd=dgesvd_
-       use openmp && [[ $(tc-getCC)$ == *gcc* ]] && \
-               append-flags -fopenmp && append-ldflags -fopenmp
-       use mpi && CC=mpicc FC=mpif77 CXX=mpicxx
-
-       cd src
-
-       # without-superlu: means do not use bundled one
-       econf \
-               --enable-shared \
-               --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')" \
-               --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')" \
-               --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')" \
-               --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')" \
-               --with-timing \
-               --without-superlu \
-               $(use_enable debug) \
-               $(use_enable openmp hopscotch) \
-               $(use_enable int64 bigint) \
-               $(use_enable fortran) \
-               $(use_with fei) \
-               $(use_with fei mli) \
-               $(use_with openmp) \
-               $(use_with mpi MPI)
-}
-
-src_compile() {
-       emake -C src
-}
-
-src_test() {
-       LD_LIBRARY_PATH="${S}/src/lib:${LD_LIBRARY_PATH}" \
-                                  PATH="${S}/src/test:${PATH}" \
-                                  emake -C src check
-}
-
-src_install() {
-       emake -C src install \
-                 HYPRE_INSTALL_DIR="${ED}" \
-                 HYPRE_LIB_INSTALL="${ED}/usr/$(get_libdir)" \
-                 HYPRE_INC_INSTALL="${ED}$/usr/include/hypre"
-       use doc && dodoc docs/*.pdf
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r src/examples
-       fi
-}
diff --git a/sci-libs/hypre/hypre-2.11.2.ebuild b/sci-libs/hypre/hypre-2.11.2.ebuild
deleted file mode 100644 (file)
index f6aa3e5..0000000
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-
-inherit cmake-utils fortran-2 toolchain-funcs flag-o-matic
-
-DESCRIPTION="Parallel matrix preconditioners library"
-HOMEPAGE="https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods"
-SRC_URI="${HOMEPAGE}/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc examples fei fortran int64 openmp mpi"
-
-RDEPEND="
-       sci-libs/superlu:=
-       virtual/blas
-       virtual/lapack
-       mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
-DOCS=( CHANGELOG COPYRIGHT README )
-
-# 2.11.1: fei and mli wrappers still buggy with big integers
-REQUIRED_USE="int64? ( !fei )"
-
-pkg_pretend() {
-       [[ ${MERGE_TYPE} != binary ]] &&\
-               use openmp && [[ $(tc-getCC)$ == *gcc* ]] && tc-check-openmp
-}
-
-pkg_setup() {
-       if [[ ${MERGE_TYPE} != binary ]] && \
-                  use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp ; then
-               ewarn "You are using a non capable gcc compiler ( < 4.2 ? )"
-               die "Need an OpenMP capable compiler"
-       fi
-}
-
-src_prepare() {
-       default
-       # link with system superlu and propagate LDFLAGS
-       sed -e "s:@LIBS@:@LIBS@ $($(tc-getPKG_CONFIG) --libs superlu):" \
-               -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
-               -i src/config/Makefile.config.in || die
-       sed -e '/HYPRE_ARCH/s: = :=:g' \
-               -i src/configure || die
-       # link with system blas and lapack
-       sed -e '/^BLASFILES/d' \
-               -e '/^LAPACKFILES/d' \
-               -i src/lib/Makefile || die
-}
-
-src_configure() {
-       tc-export CC CXX
-       append-flags -Dhypre_dgesvd=dgesvd_
-       use openmp && [[ $(tc-getCC)$ == *gcc* ]] && \
-               append-flags -fopenmp && append-ldflags -fopenmp
-       use mpi && CC=mpicc FC=mpif77 CXX=mpicxx
-
-       cd src
-
-       # without-superlu: means do not use bundled one
-       econf \
-               --enable-shared \
-               --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')" \
-               --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')" \
-               --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')" \
-               --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')" \
-               --with-timing \
-               --without-superlu \
-               $(use_enable debug) \
-               $(use_enable openmp hopscotch) \
-               $(use_enable int64 bigint) \
-               $(use_enable fortran) \
-               $(use_with fei) \
-               $(use_with fei mli) \
-               $(use_with openmp) \
-               $(use_with mpi MPI)
-}
-
-src_compile() {
-       emake -C src
-}
-
-src_test() {
-       LD_LIBRARY_PATH="${S}/src/lib:${LD_LIBRARY_PATH}" \
-                                  PATH="${S}/src/test:${PATH}" \
-                                  emake -C src check
-}
-
-src_install() {
-       emake -C src install \
-                 HYPRE_INSTALL_DIR="${ED}" \
-                 HYPRE_LIB_INSTALL="${ED}/usr/$(get_libdir)" \
-                 HYPRE_INC_INSTALL="${ED}$/usr/include/hypre"
-       use doc && dodoc docs/*.pdf
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r src/examples
-       fi
-}
diff --git a/sci-libs/hypre/hypre-2.9.0b.ebuild b/sci-libs/hypre/hypre-2.9.0b.ebuild
deleted file mode 100644 (file)
index 3228bd2..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-FORTRAN_NEEDED=fortran
-
-inherit eutils fortran-2 toolchain-funcs
-
-DESCRIPTION="Parallel matrix preconditioners library"
-HOMEPAGE="https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods"
-SRC_URI="https://computation.llnl.gov/casc/hypre/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples fortran mpi"
-
-RDEPEND="
-       sci-libs/superlu:0=
-       virtual/blas
-       virtual/lapack
-       mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
-DOCS=( "${WORKDIR}"/${P}/{CHANGELOG,COPYRIGHT,README} )
-
-S="${WORKDIR}/${P}/src"
-
-src_prepare() {
-       # link with system superlu and propagate LDFLAGS
-       sed -i \
-               -e 's:@LIBS@:@LIBS@ -lsuperlu:' \
-               -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
-               config/Makefile.config.in || die
-       sed -i \
-               -e '/HYPRE_ARCH/s: = :=:g' \
-               configure || die
-       # link with system blas and lapack
-       sed -i \
-               -e '/^BLASFILES/d' \
-               -e '/^LAPACKFILES/d' \
-               lib/Makefile || die
-       use mpi && export CC=mpicc CXX=mpicxx FC=mpif77
-       tc-export CC CXX
-}
-
-src_configure() {
-       local myeconfargs=(
-               --enable-shared
-               --without-superlu
-               --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')"
-               --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')"
-               --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')"
-               --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')"
-               $(use_enable fortran)
-               $(use_with mpi MPI)
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       dolib.so hypre/lib/lib*
-       insinto /usr/include/hypre
-       doins -r hypre/include/*
-
-       use doc && dodoc "${WORKDIR}"/${P}/docs/*.pdf
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
-       fi
-}