dev-qt/qt-creator: add mcu and webassembly plugins in 9999
authorDavide Pesavento <pesa@gentoo.org>
Sun, 27 Oct 2019 05:10:26 +0000 (06:10 +0100)
committerDavide Pesavento <pesa@gentoo.org>
Sun, 27 Oct 2019 05:52:02 +0000 (06:52 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Davide Pesavento <pesa@gentoo.org>
dev-qt/qt-creator/metadata.xml
dev-qt/qt-creator/qt-creator-9999.ebuild

index 457cf40adb4a3f27c4326c2dc22eaeb39245055d..1d779d44115b55270b01bf30db785d601ab08885 100644 (file)
                <flag name="clearcase">Add support for IBM ClearCase version control system (requires manual installation of ClearCase client)</flag>
                <flag name="cmake">Enable cmake project manager plugin</flag>
                <flag name="cppcheck">Enable integration with <pkg>dev-util/cppcheck</pkg></flag>
-               <flag name="ctfvisualizer">Build the Chrome Trace Format Visualizer plugin</flag>
+               <flag name="ctfvisualizer">Build the Chrome Trace Format visualizer plugin</flag>
                <flag name="designer">Enable designer for QtWidgets-based UIs</flag>
-               <flag name="glsl">Enable GLSL source code editor</flag>
-               <flag name="help">Build the help plugin</flag>
+               <flag name="glsl">Enable GLSL editor</flag>
+               <flag name="help">Enable the integrated documentation viewer</flag>
                <flag name="ios">Build plugin for Apple iOS devices</flag>
                <flag name="lsp">Add support for the Language Server Protocol (LSP)</flag>
+               <flag name="mcu">Build plugin for MCU devices</flag>
                <flag name="mercurial">Add support for <pkg>dev-vcs/mercurial</pkg> version control system</flag>
                <flag name="modeling">Enable graphical model editor</flag>
-               <flag name="nim">Enable Nim source code editor</flag>
+               <flag name="nim">Build plugin for Nim language support</flag>
                <flag name="perforce">Add support for Perforce version control system (requires manual installation of Perforce client)</flag>
                <flag name="perfprofiler">Build the Linux Perf-based profiler plugin</flag>
-               <flag name="python">Enable Python source code editor</flag>
+               <flag name="python">Build plugin for Python language support</flag>
                <flag name="qbs">Enable QBS project manager plugin</flag>
                <flag name="qmldesigner">Enable designer for QML/QtQuick-based UIs</flag>
                <flag name="qmlprofiler">Build the QML profiler plugin</flag>
                <flag name="qnx">Build plugin for QNX devices</flag>
-               <flag name="remotelinux">Build remotelinux plugin</flag>
+               <flag name="remotelinux">Add support for deployment and execution on a remote Linux host</flag>
                <flag name="scxml">Enable graphical SCXML editor</flag>
                <flag name="serialterminal">Build serial terminal plugin</flag>
                <flag name="silversearcher">Enable integration with <pkg>sys-apps/the_silver_searcher</pkg></flag>
                <flag name="systemd">Add support for retrieving application output from journald</flag>
-               <flag name="valgrind">Add support for memory debugging using <pkg>dev-util/valgrind</pkg></flag>
+               <flag name="valgrind">Enable integration with <pkg>dev-util/valgrind</pkg></flag>
+               <flag name="webassembly">Build WebAssembly plugin</flag>
                <flag name="webengine">Use <pkg>dev-qt/qtwebengine</pkg> to view documentation</flag>
                <flag name="winrt">Build plugin for WinRT devices</flag>
        </use>
index dbd6c1fbd7719989a131d075f1ea203558cde4a2..841fd7e86eed0f176a04e53ad1455d9807142d4a 100644 (file)
@@ -29,13 +29,14 @@ fi
 QTC_PLUGINS=(android +autotest baremetal bazaar beautifier boot2qt
        '+clang:clangcodemodel|clangformat|clangpchmanager|clangrefactoring|clangtools' clearcase
        cmake:cmakeprojectmanager cppcheck ctfvisualizer cvs +designer git glsl:glsleditor +help ios
-       lsp:languageclient mercurial modeling:modeleditor nim perforce perfprofiler python
+       lsp:languageclient mcu:mcusupport mercurial modeling:modeleditor nim perforce perfprofiler python
        qbs:qbsprojectmanager +qmldesigner qmlprofiler qnx remotelinux scxml:scxmleditor serialterminal
-       silversearcher subversion valgrind winrt)
+       silversearcher subversion valgrind webassembly winrt)
 IUSE="doc systemd test +webengine ${QTC_PLUGINS[@]%:*}"
 REQUIRED_USE="
        boot2qt? ( remotelinux )
        clang? ( test? ( qbs ) )
+       mcu? ( cmake )
        python? ( lsp )
        qnx? ( remotelinux )
 "