dev-perl/Math-PlanePath: initial ebuild, version 122.0.0
authorMatthew Brewer <tomboy64@sina.cn>
Wed, 30 Mar 2016 23:05:45 +0000 (01:05 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 3 Apr 2016 21:23:43 +0000 (23:23 +0200)
Package-Manager: portage-2.2.28
RepoMan-Options: --ignore-arches

dev-perl/Math-PlanePath/Manifest [new file with mode: 0644]
dev-perl/Math-PlanePath/Math-PlanePath-122.0.0.ebuild [new file with mode: 0644]
dev-perl/Math-PlanePath/metadata.xml [new file with mode: 0644]

diff --git a/dev-perl/Math-PlanePath/Manifest b/dev-perl/Math-PlanePath/Manifest
new file mode 100644 (file)
index 0000000..be52956
--- /dev/null
@@ -0,0 +1 @@
+DIST Math-PlanePath-122.tar.gz 1290711 SHA256 edcf64f5cb9e4cca6dd6ee88c285551ee5151438c041cdeb41a4af88f184452f SHA512 06983ab17b50da9a6872a0c154e433736720c40fc2f845de606f7089697d00d22bc1b9a8580292258af0d3d6e1133363ec2894269ed472f1fb4e52f0af2709ed WHIRLPOOL 23576d1f5d74dd5753ac236a4cf4fc1de6df25950746c78211408389e3845f3bfe3610b7f2005ff2f20c4b8874ee1977498cf027e392b3de37f9f9296ac19a22
diff --git a/dev-perl/Math-PlanePath/Math-PlanePath-122.0.0.ebuild b/dev-perl/Math-PlanePath/Math-PlanePath-122.0.0.ebuild
new file mode 100644 (file)
index 0000000..c518925
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR="KRYDE"
+DIST_VERSION="122"
+inherit perl-module
+
+DESCRIPTION="Mathematical paths through the 2-D plane"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp test examples"
+
+RDEPEND="gmp? ( dev-perl/Math-BigInt-GMP )
+       dev-perl/Math-Libm
+       dev-perl/Math-NumSeq
+       >=dev-perl/constant-defer-5.0.0
+       virtual/perl-Scalar-List-Utils
+       virtual/perl-Math-BigInt"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? ( virtual/perl-Test
+               dev-perl/Math-BigInt-Lite
+               dev-perl/Number-Fraction )"
+
+src_install() {
+       perl-module_src_install
+       if use examples; then
+               docompress -x /usr/share/doc/${PF}/examples
+               dodoc -r examples
+       fi
+}
diff --git a/dev-perl/Math-PlanePath/metadata.xml b/dev-perl/Math-PlanePath/metadata.xml
new file mode 100644 (file)
index 0000000..0a245fb
--- /dev/null
@@ -0,0 +1,144 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>tomboy64@sina.cn</email>
+               <name>Proxy-Maintainer; please assign him to bugs.</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>perl@gentoo.org</email>
+               <name>Gentoo Perl Project</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Gentoo Proxy Maintainers Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="cpan">Math-PlanePath</remote-id>
+               <remote-id type="cpan-module">Math::NumSeq::OEIS::Catalogue::Plugin::PlanePath</remote-id>
+               <remote-id type="cpan-module">Math::NumSeq::PlanePathCoord</remote-id>
+               <remote-id type="cpan-module">Math::NumSeq::PlanePathDelta</remote-id>
+               <remote-id type="cpan-module">Math::NumSeq::PlanePathN</remote-id>
+               <remote-id type="cpan-module">Math::NumSeq::PlanePathTurn</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::AlternatePaper</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::AlternatePaperMidpoint</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::AnvilSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::AR2W2Curve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::ArchimedeanChords</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::AztecDiamondRings</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Base::Digits</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Base::Generic</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Base::NSEW</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::BetaOmega</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CellularRule</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CellularRule190</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CellularRule54</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CellularRule57</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CfracDigits</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::ChanTree</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CincoCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Columns</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::ComplexMinus</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::ComplexPlus</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::ComplexRevolving</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CoprimeColumns</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Corner</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CornerReplicate</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CretanLabyrinth</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::CubicBase</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DekkingCentres</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DekkingCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DiagonalRationals</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Diagonals</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DiagonalsAlternating</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DiagonalsOctant</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DiamondArms</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DiamondSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DigitGroups</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DivisibleColumns</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DragonCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DragonMidpoint</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::DragonRounded</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::FactorRationals</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::FibonacciWordFractal</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::File</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::FilledRings</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Flowsnake</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::FlowsnakeCentres</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::FractionsTree</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::GcdRationals</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::GosperIslands</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::GosperReplicate</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::GosperSide</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::GrayCode</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::GreekKeySpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::HeptSpiralSkewed</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::HexArms</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::HexSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::HexSpiralSkewed</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::HilbertCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::HilbertSides</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::HilbertSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::HIndexing</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Hypot</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::HypotOctant</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::ImaginaryBase</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::ImaginaryHalf</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::KnightSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::KochCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::KochelCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::KochPeaks</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::KochSnowflakes</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::KochSquareflakes</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::LTiling</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::MPeaks</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::MultipleRings</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::OctagramSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::PeanoCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::PentSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::PentSpiralSkewed</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::PixelRings</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::PowerArray</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::PyramidRows</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::PyramidSides</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::PyramidSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::PythagoreanTree</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::QuadricCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::QuadricIslands</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::QuintetCentres</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::QuintetCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::QuintetReplicate</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::R5DragonCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::R5DragonMidpoint</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::RationalsTree</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Rows</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::SacksSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::SierpinskiArrowhead</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::SierpinskiArrowheadCentres</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::SierpinskiCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::SierpinskiCurveStair</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::SierpinskiTriangle</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::SquareArms</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::SquareReplicate</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::SquareSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::Staircase</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::StaircaseAlternating</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::TerdragonCurve</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::TerdragonMidpoint</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::TerdragonRounded</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::TheodorusSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::TriangleSpiral</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::TriangleSpiralSkewed</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::TriangularHypot</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::UlamWarburton</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::UlamWarburtonQuarter</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::VogelFloret</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::WunderlichMeander</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::WunderlichSerpentine</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::WythoffArray</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::WythoffPreliminaryTriangle</remote-id>
+               <remote-id type="cpan-module">Math::PlanePath::ZOrderCurve</remote-id>
+       </upstream>
+</pkgmetadata>