dev-libs/icu-le-hb: Don't install archive files
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 21 May 2020 10:16:15 +0000 (12:16 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 21 May 2020 10:16:38 +0000 (12:16 +0200)
Closes: https://bugs.gentoo.org/724432
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild [moved from dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild with 82% similarity]

similarity index 82%
rename from dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
rename to dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
index 303b08a82b8a007eb5242c974a6473001b63597d..bc67bb2c0d34f46a3815f4eb174de79b3f16d9ed 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit autotools multilib-minimal
 
@@ -22,8 +22,8 @@ RDEPEND="
        media-libs/harfbuzz:=[${MULTILIB_USEDEP}]
 "
 
-DEPEND="
-       ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
        virtual/pkgconfig[${MULTILIB_USEDEP}]
 "
 
@@ -33,5 +33,9 @@ src_prepare() {
 }
 
 multilib_src_configure() {
-       ECONF_SOURCE="${S}" econf
+       ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+       find "${ED}" -type f -name "*.la" -delete || die
 }