media-radio/gpredict: Fix build with -fno-common
authorThomas Beierlein <tomjbe@gentoo.org>
Thu, 20 Feb 2020 13:07:35 +0000 (14:07 +0100)
committerThomas Beierlein <tomjbe@gentoo.org>
Thu, 20 Feb 2020 13:08:12 +0000 (14:08 +0100)
Closes: https://bugs.gentoo.org/710196
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
media-radio/gpredict/files/gpredict-2.2.1-fno-common.patch [new file with mode: 0644]
media-radio/gpredict/gpredict-2.2.1.ebuild

diff --git a/media-radio/gpredict/files/gpredict-2.2.1-fno-common.patch b/media-radio/gpredict/files/gpredict-2.2.1-fno-common.patch
new file mode 100644 (file)
index 0000000..cdbffbe
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/src/qth-data.h b/src/qth-data.h
+index 264f66f..5c6b2de 100644
+--- a/src/qth-data.h
++++ b/src/qth-data.h
+@@ -30,7 +30,7 @@ typedef struct {
+     gint            alt;        /*!< Altitude above sea level in meters. */
+ } qth_small_t;
+-enum {
++typedef enum {
+     QTH_STATIC_TYPE = 0,
+     QTH_GPSD_TYPE
+ } qth_data_type;
index b6f1c87b12006f4230a7f6a965668e1401ca5bcf..8232248301fb21053413852d71671b33c3628715 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -28,4 +28,5 @@ src_prepare() {
        eapply_user
        # remove wrong doc location
        eapply -p0 "${FILESDIR}/${PN}-2.0-doc.patch"
+       eapply "${FILESDIR}/${P}-fno-common.patch"
 }