app-admin/tripwire: Bumps version to 2.4.3.5
authorChema Alonso Josa <nimiux@gentoo.org>
Tue, 4 Apr 2017 13:30:21 +0000 (15:30 +0200)
committerChema Alonso Josa <nimiux@gentoo.org>
Tue, 4 Apr 2017 13:30:21 +0000 (15:30 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-admin/tripwire/Manifest
app-admin/tripwire/tripwire-2.4.3.5.ebuild [new file with mode: 0644]

index 226cde1694efc54aa316a8d3ea8bc5c859ade1fa..6ef4eb72e0b17de1af81c16b7828a7c1bea340cf 100644 (file)
@@ -2,3 +2,4 @@ DIST tripwire-2.4.3.1.tar.gz 932665 SHA256 9744af4de7ecb1d643442eb22f08c81955649
 DIST tripwire-2.4.3.2.tar.gz 967679 SHA256 25588c585f1af60958b3dce5bfc28e52c3237b2690dd5f4120e9c2f42d98fd2b SHA512 f3a3d5f12178d0766356d6280b3d993c29c1091357402661f0a4bb7676c640a147b74050c64e910c1210adef11903bde463813446e2c0ee9a34038876928bdfd WHIRLPOOL ac9812f3ec41afed5951e871d0ddad64eef3514a4cae071f414c7fa10d7318393d26107bb7007ca61554c328206b0da4790f0bc400fa7ea2159eb0b4f35e8303
 DIST tripwire-2.4.3.3.tar.gz 967929 SHA256 9db1832c6ea88569b6d7fe3fe896216efeae3046cfd148a5c4102e3bbf9ac749 SHA512 977895aa169a13e786f3428386a094a56d52bf0fdc4853ac8664f0d6110774f0ff2ce4db9d5f76c52299744faa680dc03201567a458c033b2cd01df1191b96cb WHIRLPOOL 888d8676b17537895ef3c6ee2313761f78511cb092485920024595fa5dd4b61263a0125a274f52220f6f98d147a3d8122017a39965610b809d016a8ae23b4987
 DIST tripwire-2.4.3.4.tar.gz 968065 SHA256 ca0828ed624791cbe0f81f47e10f35866b73695ccd264b8341e2087b63766536 SHA512 ff47443c1c0c0248808e51df65f07aa2cbcc1d0901cc1a65830db78a1e7c4aa62c82e45827cadb1ab70281a2d4194ee3c4007050652efef9e328a98bc36f2995 WHIRLPOOL 01b3a7cdbac632928e006f21546e9040a1547ac14c9aad7cfef14f24abe0a6f333d562d1442289f79cf81bdce3ae116234890381861c9da73aa3b8828a10d7f3
+DIST tripwire-2.4.3.5.tar.gz 965014 SHA256 4bb0b400d8f5d7f8762ffb87a683f113f8c77186689cc63b8cedbbc628c9c33b SHA512 7aef0e7d38f4b6966a806a4e556636c7b2477f4ea5451e89f1749c1535a489c2f490ea13898edff5d7786acf572f77d04430115b8ddd4c6a03c38382feb45269 WHIRLPOOL f5f06d2f509e8047ede81226d3179f253e32aae4193817ab1000dd843f4b9810f6aacc6cd9c0bdc8a0c6835fdb11f79c85838a3b799d8c6565861d43dd433a99
diff --git a/app-admin/tripwire/tripwire-2.4.3.5.ebuild b/app-admin/tripwire/tripwire-2.4.3.5.ebuild
new file mode 100644 (file)
index 0000000..9bc7f61
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Open Source File Integrity Checker and IDS"
+HOMEPAGE="http://www.tripwire.org/"
+SRC_URI="https://github.com/Tripwire/tripwire-open-source/archive/${PV}.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="libressl ssl static +tools"
+
+DEPEND="sys-devel/automake
+       sys-devel/autoconf
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )"
+RDEPEND="virtual/cron
+       virtual/mta
+       ssl? ( dev-libs/openssl )"
+PDEPEND="tools? ( app-admin/mktwpol )"
+
+S="${WORKDIR}/tripwire-open-source-${PV}"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       # tripwire can be sensitive to compiler optimisation.
+       # see #32613, #45823, and others.
+       #       -taviso@gentoo.org
+       strip-flags
+       append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
+       econf $(use_enable ssl openssl) $(use_enable static)
+}
+
+src_install() {
+       dosbin "${S}"/bin/{siggen,tripwire,twadmin,twprint}
+       doman "${S}"/man/man{4/*.4,5/*.5,8/*.8}
+       dodir /etc/tripwire /var/lib/tripwire{,/report}
+       keepdir /var/lib/tripwire{,/report}
+
+       exeinto /etc/cron.daily
+       doexe "${FILESDIR}"/tripwire
+
+       dodoc ChangeLog policy/policyguide.txt TRADEMARK \
+               "${FILESDIR}"/tripwire.txt
+
+       insinto /etc/tripwire
+       doins "${FILESDIR}"/twcfg.txt policy/twpol-GENERIC.txt
+
+       fperms 750 /etc/cron.daily/tripwire
+}
+
+pkg_postinst() {
+       if [[ -z ${REPLACING_VERSIONS} ]] ; then
+               elog "Tripwire needs to be configured before its first run. You can"
+               elog "do this by manually editing the twpol-GENERIC.txt file shipped with"
+               elog "the package to suit your needs. A quickstart guide is provided"
+               elog "in tripwire.txt file to help you with this."
+               elog "To configure tripwire automatically, you can use the twsetup.sh"
+               elog "script provided by the app-admin/mktwpol package. This package is"
+               elog "installed for you by the \"tools\" USE flag (which is enabled by"
+               elog "default."
+else
+               elog "Maintenance of tripwire policy files as packages are added"
+               elog "and deleted from your system can be automated by the mktwpol.sh"
+               elog "script provided by the app-admin/mktwpol package. This package"
+               elog "is installed for you if you append \"tools\" to your USE flags"
+       fi
+}