dev-python/pyGPG: Add py3.7
authorDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 15:00:45 +0000 (17:00 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 16 Jun 2019 15:00:45 +0000 (17:00 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pyGPG/pyGPG-0.2.ebuild

index a6a797b30f4d63cab8572be97e6f6b73840f8eb7..e3d575a7cd7035342bfcb8d771adfc5e0279919a 100644 (file)
@@ -1,24 +1,28 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
+EAPI=7
 
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
 inherit distutils-r1
 
-EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+       EGIT_BRANCH="master"
+else
+       SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+       KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
+fi
 
 DESCRIPTION="A python interface wrapper for gnupg's gpg command"
 HOMEPAGE="https://github.com/dol-sen/pyGPG"
-SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
 IUSE=""
 
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
-
 DEPEND=""
 RDEPEND="${DEPEND}
        app-crypt/gnupg