net-wireless/iwd: stop using private systemd.eclass function
authorBen Kohler <bkohler@gentoo.org>
Fri, 1 Nov 2019 19:42:39 +0000 (14:42 -0500)
committerBen Kohler <bkohler@gentoo.org>
Fri, 1 Nov 2019 19:43:02 +0000 (14:43 -0500)
Just hardcode the modules-load.d dir instead of abusing a private eclass
function.

Closes: https://bugs.gentoo.org/699042
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
net-wireless/iwd/iwd-9999.ebuild

index 3a599ccce340c4c084fffc4c922ae7113b4cc34d..bef22a92049373fbf8dc773f58f357f47cc80bcd 100644 (file)
@@ -130,7 +130,7 @@ src_configure() {
                $(use_enable wired) \
                --enable-systemd-service \
                --with-systemd-unitdir="$(systemd_get_systemunitdir)" \
-               --with-systemd-modloaddir=$(_systemd_get_dir modulesloaddir /usr/lib/modules-load.d) \
+               --with-systemd-modloaddir="${EPREFIX}/usr/lib/modules-load.d" \
                --with-systemd-networkdir="$(systemd_get_utildir)/network"
        )
        [[ ${PV} == *9999* ]] || myeconfargs+=(--enable-external-ell)