dev-ros/fake_localization: Bump to 1.16.6.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 14:28:54 +0000 (16:28 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 15:18:18 +0000 (17:18 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/fake_localization/Manifest
dev-ros/fake_localization/fake_localization-1.16.6.ebuild [new file with mode: 0644]

index 5578cbccf4708685c7d2bbc20a94553d211b0d6e..a581d135557f112f25320d556b9d855bf651c6c7 100644 (file)
@@ -1,2 +1,3 @@
 DIST navigation-1.16.2.tar.gz 337389 BLAKE2B a21d014df02ebf8046245777bb42fe3bccaf65af4c607532c4fb72e0b2c43870d1ff1c32c882a0418363708c0fa0c74925943beca2110a5f19b77a65e0a871fc SHA512 890eb391a8a70b3b17aa870dfa79bf48199cf3dcf7a8703b0e005b22ffd404edf723d73e30a04f902f436899fe321894bf3da7610f374b1a95b247629f64256e
 DIST navigation-1.16.3.tar.gz 342459 BLAKE2B 736414787adee9c7511b0d90276395d33b9b52207d55ddd53836c9d77cb6809bf1946443878ad83e4461d0febf05b616b93ec0a18b34ed402323eb9bbb100861 SHA512 2eddb27fd3eff143674cc518be520e6df4d24a965689441f710105977f4bbe307736df5e6303319dde99362187091ea4f90eaec9da5a4bc678250410af174a71
+DIST navigation-1.16.6.tar.gz 346529 BLAKE2B ed2d7ddd0ca9525f0ae22711d65fc2ede5f3046fd320e5016b93505616c4d476d65128695ff8830c4fa0b8dbdc276a1ec5951fdb4d0516f4d5f70897e4759f31 SHA512 c6bc3db39457c6bccba7ee2646504c4e1c91840a3297bdb9b92b28d93c608c0de113eb92527d4f499232de628d5b49816ec42522043500b20fb04056e2a7c97f
diff --git a/dev-ros/fake_localization/fake_localization-1.16.6.ebuild b/dev-ros/fake_localization/fake_localization-1.16.6.ebuild
new file mode 100644 (file)
index 0000000..6e03c46
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="A ROS node that simply forwards odometry information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=
+       dev-ros/angles
+       dev-ros/roscpp
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-ros/rosconsole
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf2_ros
+       dev-ros/message_filters
+       dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/boost170.patch" )