Version bump, remove doc USE flag that was not doing anything.
authorMarien Zwart <marienz@gentoo.org>
Wed, 29 Nov 2006 23:54:46 +0000 (23:54 +0000)
committerMarien Zwart <marienz@gentoo.org>
Wed, 29 Nov 2006 23:54:46 +0000 (23:54 +0000)
Package-Manager: portage-2.1.2_rc2-r2

dev-python/logilab-common/ChangeLog
dev-python/logilab-common/files/digest-logilab-common-0.21.0 [new file with mode: 0644]
dev-python/logilab-common/logilab-common-0.21.0.ebuild [new file with mode: 0644]

index 321d43617dd6a9e1f209209a275e3c49fb973088..44272abac4277a18895a2e3d6ff62e87602f77a9 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-python/logilab-common
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.30 2006/09/27 00:08:45 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.31 2006/11/29 23:54:46 marienz Exp $
+
+*logilab-common-0.21.0 (29 Nov 2006)
+
+  29 Nov 2006; Marien Zwart <marienz@gentoo.org>
+  -logilab-common-0.14.0.ebuild, -logilab-common-0.14.1.ebuild,
+  +logilab-common-0.21.0.ebuild:
+  Version bump, remove doc USE flag that was not doing anything.
 
   27 Sep 2006; Marien Zwart <marienz@gentoo.org> ChangeLog:
   Add missing IUSE (recommit because I forgot repoman).
diff --git a/dev-python/logilab-common/files/digest-logilab-common-0.21.0 b/dev-python/logilab-common/files/digest-logilab-common-0.21.0
new file mode 100644 (file)
index 0000000..a75d6b9
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 623d0a4e78361a2ccd0b85e3eac53132 logilab-common-0.21.0.tar.gz 126170
+RMD160 87eb6095a4198c036b82429f3fd6300e79aa33ae logilab-common-0.21.0.tar.gz 126170
+SHA256 d9177b4f72ec589be8844dbe1a9cff150de28d9134acce3b6e2770fa6173d9cb logilab-common-0.21.0.tar.gz 126170
diff --git a/dev-python/logilab-common/logilab-common-0.21.0.ebuild b/dev-python/logilab-common/logilab-common-0.21.0.ebuild
new file mode 100644 (file)
index 0000000..67690cd
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.21.0.ebuild,v 1.1 2006/11/29 23:54:46 marienz Exp $
+
+inherit distutils
+
+DESCRIPTION="Several modules providing low level functionality shared among some python projects developed by logilab."
+HOMEPAGE="http://www.logilab.org/projects/common/"
+SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="|| ( >=dev-python/optik-1.4 >=dev-lang/python-2.3 )
+       test? ( dev-python/egenix-mx-base )"
+
+PYTHON_MODNAME="logilab"
+
+
+src_test() {
+       # The tests will not work properly from the source dir, so do a
+       # temporary install:
+       local spath="test/lib/python"
+       "${python}" setup.py install --home="${T}/test" || die "test copy failed"
+       # dir needs to be this or the tests fail
+       cd "${T}/${spath}/logilab/common/test"
+
+       # These tests will fail:
+       rm unittest_db.py
+       has userpriv ${FEATURES} || rm unittest_fileutils.py
+
+       PYTHONPATH="${T}/${spath}" "${python}" runtests.py || die "tests failed"
+       cd "${S}"
+       rm -rf "${T}/test"
+}