app-misc/gramps: support python3_8
authorMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 12:25:51 +0000 (13:25 +0100)
committerMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 12:30:52 +0000 (13:30 +0100)
Builds and tests fine, runs fine too if installed with a version of
distutils-r1.eclass not using --skip-build in the install phase.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
app-misc/gramps/gramps-5.1.2-r1.ebuild

index b05f6a7ce7894db3098d702426a64673a9bdaf3f..c13785854d7dc69d9e96530b744dfdbde59f96bc 100644 (file)
@@ -2,10 +2,11 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="sqlite"
 
 DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
 inherit distutils-r1 xdg-utils
 
 DESCRIPTION="Genealogical Research and Analysis Management Programming System"