app-shells/bash: Minor QA fixes
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 26 Apr 2020 02:40:36 +0000 (04:40 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 26 Apr 2020 02:41:07 +0000 (04:41 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-shells/bash/bash-4.4_p23-r1.ebuild
app-shells/bash/bash-5.0_p11.ebuild
app-shells/bash/bash-5.0_p16.ebuild
app-shells/bash/bash-5.0_p17.ebuild

index dc2d39a7d27f72783eeef435bbb4a1f099de454a..d40bcd6d09b1220d60d8a0071926dfb1aa56eae3 100644 (file)
@@ -56,7 +56,6 @@ DEPEND="
 "
 RDEPEND="
        ${DEPEND}
-       !<sys-apps/portage-2.1.6.7_p1
 "
 # we only need yacc when the .y files get patched (bash42-005)
 #DEPEND+=" virtual/yacc"
@@ -218,12 +217,12 @@ src_install() {
        if use examples ; then
                for d in examples/{functions,misc,scripts,startup-files} ; do
                        exeinto /usr/share/doc/${PF}/${d}
-                       insinto /usr/share/doc/${PF}/${d}
+                       docinto /usr/share/doc/${PF}/${d}
                        for f in ${d}/* ; do
                                if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
                                        doexe ${f}
                                else
-                                       doins ${f}
+                                       dodoc ${f}
                                fi
                        done
                done
index 1cb910d9157b2e8993cdee279df8828e6f8c13b6..cf6f13f0d7870c2ec4425bbbe1ba6ab8d3b4144c 100644 (file)
@@ -56,7 +56,6 @@ DEPEND="
 "
 RDEPEND="
        ${DEPEND}
-       !<sys-apps/portage-2.1.6.7_p1
 "
 # we only need yacc when the .y files get patched (bash42-005)
 #DEPEND+=" virtual/yacc"
@@ -222,12 +221,12 @@ src_install() {
        if use examples ; then
                for d in examples/{functions,misc,scripts,startup-files} ; do
                        exeinto /usr/share/doc/${PF}/${d}
-                       insinto /usr/share/doc/${PF}/${d}
+                       docinto /usr/share/doc/${PF}/${d}
                        for f in ${d}/* ; do
                                if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
                                        doexe ${f}
                                else
-                                       doins ${f}
+                                       dodoc ${f}
                                fi
                        done
                done
index 1cb910d9157b2e8993cdee279df8828e6f8c13b6..cf6f13f0d7870c2ec4425bbbe1ba6ab8d3b4144c 100644 (file)
@@ -56,7 +56,6 @@ DEPEND="
 "
 RDEPEND="
        ${DEPEND}
-       !<sys-apps/portage-2.1.6.7_p1
 "
 # we only need yacc when the .y files get patched (bash42-005)
 #DEPEND+=" virtual/yacc"
@@ -222,12 +221,12 @@ src_install() {
        if use examples ; then
                for d in examples/{functions,misc,scripts,startup-files} ; do
                        exeinto /usr/share/doc/${PF}/${d}
-                       insinto /usr/share/doc/${PF}/${d}
+                       docinto /usr/share/doc/${PF}/${d}
                        for f in ${d}/* ; do
                                if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
                                        doexe ${f}
                                else
-                                       doins ${f}
+                                       dodoc ${f}
                                fi
                        done
                done
index 1cb910d9157b2e8993cdee279df8828e6f8c13b6..cf6f13f0d7870c2ec4425bbbe1ba6ab8d3b4144c 100644 (file)
@@ -56,7 +56,6 @@ DEPEND="
 "
 RDEPEND="
        ${DEPEND}
-       !<sys-apps/portage-2.1.6.7_p1
 "
 # we only need yacc when the .y files get patched (bash42-005)
 #DEPEND+=" virtual/yacc"
@@ -222,12 +221,12 @@ src_install() {
        if use examples ; then
                for d in examples/{functions,misc,scripts,startup-files} ; do
                        exeinto /usr/share/doc/${PF}/${d}
-                       insinto /usr/share/doc/${PF}/${d}
+                       docinto /usr/share/doc/${PF}/${d}
                        for f in ${d}/* ; do
                                if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
                                        doexe ${f}
                                else
-                                       doins ${f}
+                                       dodoc ${f}
                                fi
                        done
                done