dev-python/curtsies: py37 + py38 + QA fixes
authorSebastian Pipping <sping@gentoo.org>
Sat, 7 Mar 2020 17:34:46 +0000 (18:34 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sat, 7 Mar 2020 17:56:30 +0000 (18:56 +0100)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.92, Repoman-2.3.20

dev-python/curtsies/curtsies-0.3.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/curtsies/curtsies-0.3.0-r2.ebuild b/dev-python/curtsies/curtsies-0.3.0-r2.ebuild
new file mode 100644 (file)
index 0000000..bf4116b
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="https://github.com/thomasballinger/curtsies"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+       >=dev-python/wcwidth-0.1.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/pyte[${PYTHON_USEDEP}]
+       )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-typing.patch )
+
+python_test() {
+       nosetests --verbose tests || die
+}