dev-libs/rapidjson: A fast JSON parser/generator for C++ with both SAX/DOM style API
authorCraig Andrews <candrews@integralblue.com>
Tue, 28 Mar 2017 03:09:35 +0000 (23:09 -0400)
committerDavid Seifert <soap@gentoo.org>
Sat, 1 Apr 2017 10:20:41 +0000 (12:20 +0200)
Gentoo-bug: 614100
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Closes: https://github.com/gentoo/gentoo/pull/4310

dev-libs/rapidjson/Manifest [new file with mode: 0644]
dev-libs/rapidjson/metadata.xml [new file with mode: 0644]
dev-libs/rapidjson/rapidjson-1.1.0.ebuild [new file with mode: 0644]
dev-libs/rapidjson/rapidjson-9999.ebuild [new file with mode: 0644]

diff --git a/dev-libs/rapidjson/Manifest b/dev-libs/rapidjson/Manifest
new file mode 100644 (file)
index 0000000..f6b84ff
--- /dev/null
@@ -0,0 +1 @@
+DIST rapidjson-1.1.0.tar.gz 1019402 SHA256 bf7ced29704a1e696fbccf2a2b4ea068e7774fa37f6d7dd4039d0787f8bed98e SHA512 2e82a4bddcd6c4669541f5945c2d240fb1b4fdd6e239200246d3dd50ce98733f0a4f6d3daa56f865d8c88779c036099c52a9ae85d47ad263686b68a88d832dff WHIRLPOOL 01863b2fd4270776bea95530a15a815a9b27f8157250d59889351b154fcc591643c6f1071371bf667935833229c93ba8c2de803d9263491d79d73594c05003aa
diff --git a/dev-libs/rapidjson/metadata.xml b/dev-libs/rapidjson/metadata.xml
new file mode 100644 (file)
index 0000000..8d243cc
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>candrews@integralblue.com</email>
+               <name>Craig Andrews</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <bugs-to>https://github.com/miloyip/rapidjson/issues</bugs-to>
+               <remote-id type="github">miloyip/rapidjson</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-libs/rapidjson/rapidjson-1.1.0.ebuild b/dev-libs/rapidjson/rapidjson-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..8f3a254
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A fast JSON parser/generator for C++ with both SAX/DOM style API"
+HOMEPAGE="http://rapidjson.org/"
+
+LICENSE="MIT"
+IUSE="doc examples test"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="git://github.com/miloyip/rapidjson.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/miloyip/rapidjson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/rapidjson-${PV}"
+fi
+
+DEPEND="
+       doc? ( app-doc/doxygen )
+       test? (
+               dev-cpp/gtest
+               dev-util/valgrind
+       )"
+RDEPEND=""
+
+src_configure() {
+       local mycmakeargs=(
+               -DRAPIDJSON_BUILD_DOC=$(usex doc)
+               -DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
+               -DRAPIDJSON_BUILD_TESTS=$(usex test)
+               -DRAPIDJSON_BUILD_THIRDPARTY_GTEST=OFF
+       )
+       cmake-utils_src_configure
+}
diff --git a/dev-libs/rapidjson/rapidjson-9999.ebuild b/dev-libs/rapidjson/rapidjson-9999.ebuild
new file mode 100644 (file)
index 0000000..8f3a254
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A fast JSON parser/generator for C++ with both SAX/DOM style API"
+HOMEPAGE="http://rapidjson.org/"
+
+LICENSE="MIT"
+IUSE="doc examples test"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="git://github.com/miloyip/rapidjson.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/miloyip/rapidjson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/rapidjson-${PV}"
+fi
+
+DEPEND="
+       doc? ( app-doc/doxygen )
+       test? (
+               dev-cpp/gtest
+               dev-util/valgrind
+       )"
+RDEPEND=""
+
+src_configure() {
+       local mycmakeargs=(
+               -DRAPIDJSON_BUILD_DOC=$(usex doc)
+               -DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
+               -DRAPIDJSON_BUILD_TESTS=$(usex test)
+               -DRAPIDJSON_BUILD_THIRDPARTY_GTEST=OFF
+       )
+       cmake-utils_src_configure
+}