dev-ros/pointcloud_to_laserscan: bump to 1.4.0
authorAlexis Ballier <aballier@gentoo.org>
Fri, 17 Nov 2017 13:08:49 +0000 (14:08 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 17 Nov 2017 13:08:58 +0000 (14:08 +0100)
Package-Manager: Portage-2.3.14, Repoman-2.3.6

dev-ros/pointcloud_to_laserscan/Manifest
dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.0.ebuild [new file with mode: 0644]

index fd2c066d23c1ba62a1649f92b803e423532b01b1..bb9d075cfb3b0a9ded421c6d3caa5778514feca6 100644 (file)
@@ -1 +1,2 @@
 DIST pointcloud_to_laserscan-1.3.1.tar.gz 6239 SHA256 345161557c13c395d89aaf63c44d00514e81208db806814d9596495e6396ce41 SHA512 2356de7b7778b396775f4e2a9b2b9fe9f0329f514577820686c1d477fcd9423622df0351551bfe9111ef33a105859f42612e7d8e3c2c39328e224a836fc4d34b WHIRLPOOL 3999c0f469e9efebcf78614abd12152776548ed013daf1fa7ccf66fce422421aa933972c7e0566516e158eb6d7535e759a4601b0749e6d010bcd26c0b34b15e2
+DIST pointcloud_to_laserscan-1.4.0.tar.gz 6502 SHA256 45078c05907c4abffb7231dc30d128813b039dbb1f9702552e61b319fb5033ca SHA512 f54d65edc4eda2e97d75ed26b1d374a669f188c4ef2426730312ae479e051a0834abb782cdd00febbd8dc97cb6a0723b6a735d2cbf07e2f8260ad0e54e79376f WHIRLPOOL cf32a8342a0443235692c2d522162b126ed4eef6a5b1abcb350f8ad69b7dcb97c4e3805963ea5cad878696adebe409786316687a2fb166e33eccd62fabad2167
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.0.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..74ea496
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a 3D Point Cloud into a 2D laser scan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/message_filters
+       dev-ros/nodelet
+       dev-ros/roscpp
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf2
+       dev-ros/tf2_ros
+       dev-ros/tf2_sensor_msgs
+       dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"