Remove 6.4 since 6.4.1 is stable and 6.4 was rather buggy anyway.
authorDuncan Coutts <dcoutts@gentoo.org>
Mon, 27 Mar 2006 12:38:49 +0000 (12:38 +0000)
committerDuncan Coutts <dcoutts@gentoo.org>
Mon, 27 Mar 2006 12:38:49 +0000 (12:38 +0000)
Package-Manager: portage-2.1_pre5-r4

dev-lang/ghc/ChangeLog
dev-lang/ghc/Manifest
dev-lang/ghc/files/digest-ghc-6.4 [deleted file]
dev-lang/ghc/ghc-6.4.ebuild [deleted file]

index a4747af6fd734d8a709686976dc5286048c9188b..7c599c69198a9bdd469a269e1853b049a89b3870 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-lang/ghc
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.90 2006/03/27 11:39:32 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.91 2006/03/27 12:38:49 dcoutts Exp $
+
+  27 Mar 2006; Duncan Coutts <dcoutts@gentoo.org> -ghc-6.4.ebuild:
+  Remove 6.4 since 6.4.1 is stable and 6.4 was rather buggy anyway.
 
   27 Mar 2006; Duncan Coutts <dcoutts@gentoo.org>
   +files/ghc-6.4.1-gcc41.patch:
index 4314e79788365e535150eadfdd5f6319529997c1..ba7b3eaebd9ca55c24599e2779cd3332e39b7309 100644 (file)
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
 MD5 ea5a5716c67be90027002146b50dcebe ChangeLog 15837
 RMD160 f05aa0de0e1a6c935eff68b261c204bcd8d532cd ChangeLog 15837
 SHA256 59727977db06f680dbed9f032b1870d8dba94b83e709893b18c85c3187e20bb7 ChangeLog 15837
@@ -43,3 +46,10 @@ SHA256 74ed9295c19cf20e1051740528325bb4c553a8a5c8507ee6ae8beb0873d5b9dd ghc-6.4.
 MD5 c694674dcbef799cd4fdb6914683ebff metadata.xml 223
 RMD160 7783e6057effb8b8f0b79cffe8b557b32c633839 metadata.xml 223
 SHA256 1d00c8be162a6cb87b3de440b3e63e10b39c12d56e8fbfe592e75aed872b2508 metadata.xml 223
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2.2 (GNU/Linux)
+
+iD8DBQFEJ9zT/B0cxt+cq+wRAtxeAJsGdtYu3cqcIamt/iYfEf4A1zN2UACfVV4/
+SfxB1zwR2XVqFgkFNGdpVZE=
+=/5Nd
+-----END PGP SIGNATURE-----
diff --git a/dev-lang/ghc/files/digest-ghc-6.4 b/dev-lang/ghc/files/digest-ghc-6.4
deleted file mode 100644 (file)
index fa4a97b..0000000
+++ /dev/null
@@ -1 +0,0 @@
-MD5 45ea4e15f135698feb88d12c5000aaf8 ghc-6.4-src.tar.bz2 6899502
diff --git a/dev-lang/ghc/ghc-6.4.ebuild b/dev-lang/ghc/ghc-6.4.ebuild
deleted file mode 100644 (file)
index 09ebd0a..0000000
+++ /dev/null
@@ -1,218 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.ebuild,v 1.9 2005/08/31 17:41:05 gustavoz Exp $
-
-# Brief explanation of the bootstrap logic:
-#
-# ghc requires ghc-bin to bootstrap.
-# Therefore, 
-# (1) both ghc-bin and ghc provide virtual/ghc
-# (2) virtual/ghc *must* default to ghc-bin
-# (3) ghc depends on virtual/ghc
-#
-# This solution has the advantage that the binary distribution
-# can be removed once an forall after the first succesful install
-# of ghc.
-
-inherit base flag-o-matic eutils ghc-package
-
-IUSE="doc java opengl"
-
-DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
-
-# discover if this is a snapshot release
-IS_SNAPSHOT="${PV%%*pre*}" # zero if snapshot
-MY_PV="${PV/_pre/.}"
-MY_P="${PN}-${MY_PV}"
-EXTRA_SRC_URI="${MY_PV}"
-[[ -z "${IS_SNAPSHOT}" ]] && EXTRA_SRC_URI="stable/dist"
-
-SRC_URI="http://www.haskell.org/ghc/dist/${EXTRA_SRC_URI}/${MY_P}-src.tar.bz2"
-
-LICENSE="as-is"
-SLOT="0"
-# re-add ~ppc64 once dependencies are fulfilled
-KEYWORDS="-alpha ~amd64 ~ppc ~sparc ~x86"
-
-S="${WORKDIR}/${MY_P}"
-
-PROVIDE="virtual/ghc"
-# FIXME: Add USE support for parallel haskell (requires PVM)
-#       Get PVM from ftp://ftp.netlib.org/pvm3/
-DEPEND="virtual/ghc
-       >=dev-lang/perl-5.6.1
-       >=sys-devel/gcc-2.95.3
-       >=sys-devel/make-3.79.1
-       >=sys-apps/sed-3.02.80
-       >=sys-devel/flex-2.5.4a
-       >=dev-libs/gmp-4.1
-       >=sys-libs/readline-4.2
-       doc? (  ~app-text/docbook-xml-dtd-4.2
-               app-text/docbook-xsl-stylesheets
-               >=dev-libs/libxslt-1.1.2
-               >=dev-haskell/haddock-0.6-r2
-               java? ( >=dev-java/fop-0.20.5 ) )
-       opengl? ( virtual/opengl
-               virtual/glu
-               virtual/glut )"
-
-RDEPEND="virtual/libc
-       >=sys-devel/gcc-2.95.3
-       >=dev-lang/perl-5.6.1
-       >=dev-libs/gmp-4.1
-       >=sys-libs/readline-4.2
-       opengl? ( virtual/opengl virtual/glu virtual/glut )"
-
-SUPPORTED_CFLAGS=""
-
-# Setup supported CFLAGS.
-check_cflags() {
-       OLD_CFLAGS="${CFLAGS}"
-       CFLAGS="$1"
-       strip-unsupported-flags
-       SUPPORTED_CFLAGS="${SUPPORTED_CFLAGS} ${CFLAGS}"
-       CFLAGS="${OLD_CFLAGS}"
-}
-
-setup_cflags() {
-       check_cflags "-nopie -fno-stack-protector -fno-stack-protector-all"
-}
-
-# Portage's resolution of virtuals fails on virtual/ghc in some Portage releases,
-# the following function causes the build to fail with an informative error message
-# in such a case.
-pkg_setup() {
-       if ! has_version virtual/ghc; then
-               eerror "This ebuild needs a version of GHC to bootstrap from."
-               eerror "Please emerge dev-lang/ghc-bin to get a binary version."
-               eerror "You can either use the binary version directly or emerge"
-               eerror "dev-lang/ghc afterwards."
-               die "virtual/ghc version required to build"
-       fi
-}
-
-src_unpack() {
-       base_src_unpack
-
-       # This patch is needed for both ppc & ppc64
-       epatch ${FILESDIR}/ghc-6.4-powerpc.patch
-
-       # hardened-gcc needs to be disabled, because the
-       # mangler doesn't accept its output; yes, the 6.2 version
-       # should do ...
-       cd ${S}/ghc
-       pushd driver
-       setup_cflags
-
-       epatch ${FILESDIR}/${PN}-6.2.hardened.patch
-       sed -i -e "s|@GHC_CFLAGS@|${SUPPORTED_CFLAGS// -/ -optc-}|" ghc/ghc.sh
-       sed -i -e "s|@GHC_CFLAGS@|${SUPPORTED_CFLAGS// -/ -optc-}|" ghci/ghci.sh
-       popd
-
-       cd docs/users_guide/
-       # use versionator or something
-       # epatch ${FILESDIR}/ghc-6.4-docbook.patch
-
-       cd ${S}/libraries
-       sed -i -e "s|I/O|I\\\\/O|" template-haskell/Language/Haskell/TH/Syntax.hs
-}
-
-src_compile() {
-       local myconf
-       local mydoc
-
-       if use opengl; then
-               myconf="--enable-hopengl"
-       fi
-
-       # initialize build.mk
-       echo '# Gentoo changes' > mk/build.mk
-
-       # determine what to do with documentation
-       if use doc; then
-               mydoc="html"
-               if use java; then
-                       mydoc="${mydoc} ps"
-               fi
-       else
-               mydoc=""
-               # needed to prevent haddock from being called
-               echo NO_HADDOCK_DOCS=YES >> mk/build.mk
-       fi
-       echo XMLDocWays="${mydoc}" >> mk/build.mk
-
-       # disable the automatic PIC building which is considered as Prologue Junk by the Haskell Compiler
-       # thanks to Peter Simons for finding this and giving notice on bugs.gentoo.org
-       # (this is still necessary, even though we have the patch, because
-       # we might be bootstrapping from a version that didn't have the
-       # patch included)
-       setup_cflags
-       echo "SRC_CC_OPTS+=${SUPPORTED_CFLAGS}" >> mk/build.mk
-       echo "SRC_HC_OPTS+=${SUPPORTED_CFLAGS// -/ -optc-}" >> mk/build.mk
-
-       # force the config variable ArSupportsInput to be unset;
-       # ar in binutils >= 2.14.90.0.8-r1 seems to be classified
-       # incorrectly by the configure script
-       echo "ArSupportsInput:=" >> mk/build.mk
-
-       # Required for some architectures, because they don't support ghc fully ...
-       use ppc || use ppc64 || use amd64 && echo "SplitObjs=NO" >> mk/build.mk
-       use amd64 || use ppc64 && echo "GhcWithInterpreter=NO" >> mk/build.mk
-
-       # (--enable-threaded-rts is no longer needed)
-       econf ${myconf} || die "econf failed"
-
-       # the build does not seem to work all that
-       # well with parallel make
-       emake -j1 all || die "make failed"
-
-       # if documentation has been requested, build documentation ...
-       # if use doc; then
-       #       emake -j1 html || die "make html failed"
-       #       if use java; then
-       #               emake -j1 ps || die "make ps failed"
-       #       fi
-       # fi
-
-}
-
-src_install () {
-       local insttarget
-
-       insttarget="install"
-       use doc && insttarget="${insttarget} install-docs"
-
-       # the libdir0 setting is needed for amd64, and does not
-       # harm for other arches
-       emake -j1 ${insttarget} \
-               prefix="${D}/usr" \
-               datadir="${D}/usr/share/doc/${PF}" \
-               infodir="${D}/usr/share/info" \
-               mandir="${D}/usr/share/man" \
-               libdir0="${D}/usr/$(get_libdir)" \
-               || die "make ${insttarget} failed"
-
-       #need to remove ${D} from ghcprof script
-       cd ${D}/usr/bin
-       mv ghcprof ghcprof-orig
-       sed -e 's:$FPTOOLS_TOP_ABS:#$FPTOOLS_TOP_ABS:' ghcprof-orig > ghcprof
-       chmod a+x ghcprof
-       rm -f ghcprof-orig
-
-       cd ${S}/ghc
-       dodoc README ANNOUNCE LICENSE VERSION
-
-       dosbin ${FILESDIR}/ghc-updater
-}
-
-pkg_postinst () {
-       ghc-reregister
-       einfo "If you have dev-lang/ghc-bin installed, you might"
-       einfo "want to unmerge it. It is no longer needed."
-       einfo
-       ewarn "If you upgrade from another ghc version, please run"
-       ewarn "/usr/sbin/ghc-updater to re-merge all ghc-based"
-       ewarn "Haskell libraries."
-}
-