sys-apps/bubblewrap: new ebuild
authorSobhan Mohammadpour <sobhan@gentoo.org>
Mon, 15 Oct 2018 17:17:38 +0000 (20:47 +0330)
committerSobhan Mohammadpour <sobhan@gentoo.org>
Mon, 15 Oct 2018 17:19:21 +0000 (20:49 +0330)
bubblewrap is a lightweight setuid sandbox application
developed from Flatpak with a small installation footprint and
minimal resource requirements.

Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
sys-apps/bubblewrap/Manifest [new file with mode: 0644]
sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild [new file with mode: 0644]
sys-apps/bubblewrap/metadata.xml [new file with mode: 0644]

diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
new file mode 100644 (file)
index 0000000..dba0bcb
--- /dev/null
@@ -0,0 +1 @@
+DIST bubblewrap-0.3.1.tar.gz 62768 BLAKE2B a8c29102f9b69bfbd6b6aebb9aa0878bd1e31b52a6cb6374b8341c1410526872d4063ff0524ab4f98d7cac7358dad3190144d12bb0b11cf26eeed2730c4ec475 SHA512 fbc44976f53fdf8913b94c57d1f26a3b87c773e86a289e58fd3d7b1c4ea7f33c862f1a38a4f791315358990928768a68334f0a171302c18a16c7e2e9f1a146dd
diff --git a/sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild
new file mode 100644 (file)
index 0000000..56d2c9c
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools bash-completion-r1 linux-info
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/projectatomic/bubblewrap"
+SRC_URI="https://github.com/projectatomic/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="selinux"
+
+DEPEND="
+       dev-libs/libxslt
+       sys-libs/libseccomp
+       sys-libs/libcap
+       selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+# FIXME: we don't need bashcomp righ??
+RDEPEND="${DEPEND}"
+# FIXME: bash comp is not working
+# FIXME: test is not working
+pkg_setup() {
+       if [[ ${MERGE_TYPE} != buildonly ]]; then
+               CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+               linux-info_pkg_setup
+       fi
+}
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+
+       econf \
+               $(use_enable selinux) \
+               "--enable-man" \
+               "--with-bash-completion-dir=${get_bashcompdir}" \
+               "--with-priv-mode=none"
+}
+
+pkg_postinst() {
+       einfo "bashcomp can be used with >=app-shells/bash-completion-2.0"
+       einfo "probably needs namespaces"
+}
diff --git a/sys-apps/bubblewrap/metadata.xml b/sys-apps/bubblewrap/metadata.xml
new file mode 100644 (file)
index 0000000..3998080
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>gnome@gentoo.org</email>
+       <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>