dev-libs/libinput: Drop old versions
authorMatt Turner <mattst88@gentoo.org>
Tue, 26 Nov 2019 22:39:27 +0000 (17:39 -0500)
committerMatt Turner <mattst88@gentoo.org>
Tue, 26 Nov 2019 22:45:29 +0000 (17:45 -0500)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/libinput/Manifest
dev-libs/libinput/libinput-1.14.1.ebuild [deleted file]
dev-libs/libinput/libinput-1.14.2.ebuild [deleted file]

index 08f9cc195b49868d4147e0f32e87cc51e5087175..90987951333eafd7b40a83638757924215b7fc29 100644 (file)
@@ -1,3 +1 @@
-DIST libinput-1.14.1.tar.xz 564412 BLAKE2B 185cede0e5d74dc27f544996aa003d50556ef50f432c73a45a1cffeac921ecc0a5c5c82158292bcd18a692d745fed552545e5ab60bcc29fb1451529cbdc7a57e SHA512 8416bab51ba1aab924fa1b41360bc2ad101fb60d3a82c73584bb1e2454554524716673e3eac7f08c18bd6a1ecdfa52ea3cfe09c7a866c59fcd47d75960e82d4c
-DIST libinput-1.14.2.tar.xz 566976 BLAKE2B 498b7032122b2d757e691663bde9ca0025af92d33a5e4b03bf9ce87ec8a4d4c47fe07939583d7450626208ca761efde2de14a327e0fcd794699cc9b72b928e79 SHA512 932949a78bf95a7a05f50170cfc7dc109c99e1e3e70e63797566c0c3a3003632cad56e9b9ca2a180880f5e2ec1060613066d068b384096f37785fe70ac30c1eb
 DIST libinput-1.14.3.tar.xz 567560 BLAKE2B 76d38b795a5e721a73062e9c37b23bf6739291549cadc66401ef47b1a9afd5766f1d0ed855fc66912e4257fae4b1b813946c67246adb8d8566d5ad9478079636 SHA512 f01d1bd1b25b8060519575644597d35f0c89de5386d298441f440128ceee3e57549921a058adec31adc8b33dbdedf4c0bd12c76905a69f752859d3136e26336d
diff --git a/dev-libs/libinput/libinput-1.14.1.ebuild b/dev-libs/libinput/libinput-1.14.1.ebuild
deleted file mode 100644 (file)
index 2a1ff84..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 2014-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit meson python-any-r1 udev
-
-DESCRIPTION="Library to handle input devices in Wayland"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/10"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 sparc x86"
-IUSE="doc input_devices_wacom"
-# Tests require write access to udev rules directory which is a no-no for live system.
-# Other tests are just about logs, exported symbols and autotest of the test library.
-RESTRICT="test"
-
-BDEPEND="
-       virtual/pkgconfig
-       doc? (
-               $(python_gen_any_dep '
-                       dev-python/commonmark[${PYTHON_USEDEP}]
-                       dev-python/recommonmark[${PYTHON_USEDEP}]
-                       dev-python/sphinx[${PYTHON_USEDEP}]
-                       >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
-               ')
-               >=app-doc/doxygen-1.8.3
-               >=media-gfx/graphviz-2.38.0
-       )
-"
-#      test? ( dev-util/valgrind )
-RDEPEND="
-       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
-       >=dev-libs/libevdev-1.3
-       >=sys-libs/mtdev-1.1
-       virtual/libudev:=
-       virtual/udev
-"
-DEPEND="${RDEPEND}"
-#      test? ( >=dev-libs/check-0.9.10 )
-
-python_check_deps() {
-       has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
-       has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
-       has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
-       has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
-       use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
-       # gui can be built but will not be installed
-       local emesonargs=(
-               -Ddebug-gui=false
-               $(meson_use doc documentation)
-               $(meson_use input_devices_wacom libwacom)
-               -Dtests=false # tests are restricted
-               -Dudev-dir="$(get_udevdir)"
-       )
-       meson_src_configure
-}
-
-src_install() {
-       meson_src_install
-       if use doc ; then
-               docinto html
-               dodoc -r "${BUILD_DIR}"/Documentation/.
-       fi
-}
-
-pkg_postinst() {
-       udevadm hwdb --update --root="${ROOT}"
-}
diff --git a/dev-libs/libinput/libinput-1.14.2.ebuild b/dev-libs/libinput/libinput-1.14.2.ebuild
deleted file mode 100644 (file)
index c6c5651..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 2014-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit meson python-any-r1 udev
-
-DESCRIPTION="Library to handle input devices in Wayland"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/10"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc input_devices_wacom"
-# Tests require write access to udev rules directory which is a no-no for live system.
-# Other tests are just about logs, exported symbols and autotest of the test library.
-RESTRICT="test"
-
-BDEPEND="
-       virtual/pkgconfig
-       doc? (
-               $(python_gen_any_dep '
-                       dev-python/commonmark[${PYTHON_USEDEP}]
-                       dev-python/recommonmark[${PYTHON_USEDEP}]
-                       dev-python/sphinx[${PYTHON_USEDEP}]
-                       >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
-               ')
-               >=app-doc/doxygen-1.8.3
-               >=media-gfx/graphviz-2.38.0
-       )
-"
-#      test? ( dev-util/valgrind )
-RDEPEND="
-       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
-       >=dev-libs/libevdev-1.3
-       >=sys-libs/mtdev-1.1
-       virtual/libudev:=
-       virtual/udev
-"
-DEPEND="${RDEPEND}"
-#      test? ( >=dev-libs/check-0.9.10 )
-
-python_check_deps() {
-       has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
-       has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
-       has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
-       has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
-       use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
-       # gui can be built but will not be installed
-       local emesonargs=(
-               -Ddebug-gui=false
-               $(meson_use doc documentation)
-               $(meson_use input_devices_wacom libwacom)
-               -Dtests=false # tests are restricted
-               -Dudev-dir="$(get_udevdir)"
-       )
-       meson_src_configure
-}
-
-src_install() {
-       meson_src_install
-       if use doc ; then
-               docinto html
-               dodoc -r "${BUILD_DIR}"/Documentation/.
-       fi
-}
-
-pkg_postinst() {
-       udevadm hwdb --update --root="${ROOT}"
-}