dev-python/requests-ntlm: add python 3.7
authorBernard Cafarelli <voyageur@gentoo.org>
Fri, 21 Feb 2020 14:04:52 +0000 (15:04 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Fri, 21 Feb 2020 14:11:05 +0000 (15:11 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
dev-python/requests-ntlm/requests-ntlm-1.1.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/requests-ntlm/requests-ntlm-1.1.0-r1.ebuild b/dev-python/requests-ntlm/requests-ntlm-1.1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..c0761e9
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+
+DESCRIPTION="HTTP NTLM authentication using the requests library"
+HOMEPAGE="https://github.com/requests/requests-ntlm"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+       >=dev-python/ntlm-auth-1.0.2[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}