x11-libs/cairo: Drop IUSE=xcb
authorMatt Turner <mattst88@gentoo.org>
Tue, 14 Jan 2020 21:07:01 +0000 (13:07 -0800)
committerMatt Turner <mattst88@gentoo.org>
Tue, 14 Jan 2020 21:07:01 +0000 (13:07 -0800)
Cairo's USE=X depends on libX11 which unconditionally depends on libxcb,
so IUSE=xcb is pretty silly. I guess you could have built with USE="-X
xcb" but why would you do that... Just include it within USE=X.

Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/cairo/cairo-1.16.0-r3.ebuild
x11-libs/cairo/cairo-9999.ebuild

index 1c3590a8d2a16b1e67bc1b117745b47ee5914ce8..35ca0745c48e0309e0c7dcaaf9dd7f543bfb157d 100644 (file)
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
 HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="0"
-IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind"
 # gtk-doc regeneration doesn't seem to work with out-of-source builds
 #[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
 
@@ -43,8 +43,6 @@ RDEPEND="
                >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
                >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
                >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
-       )
-       xcb? (
                >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
        )"
 DEPEND="${RDEPEND}
@@ -110,14 +108,14 @@ multilib_src_configure() {
                $(use_enable svg) \
                $(use_enable utils trace) \
                $(use_enable valgrind) \
-               $(use_enable xcb) \
-               $(use_enable xcb xcb-shm) \
                --enable-ft \
+               --enable-interpreter \
                --enable-pdf \
                --enable-png \
                --enable-ps \
                --enable-script \
-               --enable-interpreter \
+               --enable-xcb
+               --enable-xcb-shm
                --disable-drm \
                --disable-directfb \
                --disable-gallium \
index 6b69a9ab32b6d60cad85b441442508544b71bd07..45d38bca293a053883b0d5d0d9741b423011d5d3 100644 (file)
@@ -18,7 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
 HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
 SLOT="0"
-IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind xcb"
+IUSE="X aqua debug gles2 +glib opengl static-libs +svg utils valgrind"
 # gtk-doc regeneration doesn't seem to work with out-of-source builds
 #[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
 
@@ -43,8 +43,6 @@ RDEPEND="
                >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
                >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
                >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
-       )
-       xcb? (
                >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
        )"
 DEPEND="${RDEPEND}
@@ -108,14 +106,14 @@ multilib_src_configure() {
                $(use_enable svg) \
                $(use_enable utils trace) \
                $(use_enable valgrind) \
-               $(use_enable xcb) \
-               $(use_enable xcb xcb-shm) \
                --enable-ft \
+               --enable-interpreter \
                --enable-pdf \
                --enable-png \
                --enable-ps \
                --enable-script \
-               --enable-interpreter \
+               --enable-xcb
+               --enable-xcb-shm
                --disable-drm \
                --disable-directfb \
                --disable-gallium \