media-gfx/iscan: Remove humongous relative symlink hack
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 09:38:34 +0000 (10:38 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 09:39:38 +0000 (10:39 +0100)
The gimp plugin directory path is predictable, we do not need to call
realpath for it.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-gfx/iscan/iscan-2.30.4.2.ebuild

index 90d8c1c878c273fdd2ad42fd058e5698cb976b0a..4be72d1812883d608bffada01275a87bcff343bc 100644 (file)
@@ -126,7 +126,7 @@ src_install() {
                done
                if [[ "/plug-ins" != "${gimpplugindir}" ]]; then
                        dodir ${gimpplugindir}
-                       dosym $(realpath -s --relative-to="${gimpplugindir}" "${EPREFIX}/usr/bin/iscan" || die) "${gimpplugindir}"/iscan
+                       dosym ../../../../bin/iscan "${gimpplugindir}"/iscan
                else
                        ewarn "No idea where to find the gimp plugin directory"
                fi